E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.


Go Back   E46Fanatics > Members List

roadtrip1098 roadtrip1098 is offline

Registered User

Visitor Messages

Showing Visitor Messages 1 to 6 of 6
  1. roadtrip1098
    06-23-2014 02:32 PM
    roadtrip1098
    Sent you a PM.
  2. m3babay
    06-22-2014 08:16 PM
    m3babay
    my car wont start cog light is on the pump is not priming i alredy replaced the salmon relay and nothing
  3. roadtrip1098
    03-29-2013 10:46 AM
    roadtrip1098
    I've had good luck with Turner Motor Sports.
  4. John 3:16
    03-09-2013 03:44 PM
    John 3:16
    Hi Ive just asked the following question on on the trouble shooting thread but Im hoping this will short circuit the process. Where can I source the compression springs in the USA? This is the first time I hear of this potential problem
  5. roadtrip1098
    04-25-2012 06:28 AM
    roadtrip1098
    Most common issue with that is to try pressing the brake a little harder. If that doesn't work, try unplugging the battery for 10 minutes and try again. If the pump primes and then shuts off then your pump and accumulator are both good. Will it go into first if you shut off the car and put it in?
  6. ak89
    04-24-2012 11:53 AM
    ak89
    Hi I have 2002 M3 smg. And I have M3 that starts up but doesn't let me select r or n. Just blinked n. Hood doors. Ect. Are closed properly. Change relay and still nothing. Smg pump primes. Any idea wat it could be. Also the smg light is on

About Me

  • About roadtrip1098
    Location
    Winslow, ME
    My Ride
    04 M3 SMG LSB
    Interests
    Turning Wrenches, Drinking Beer
    Occupation
    Military
    How many BMW cars have you owned?
    2

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 11-04-2014 11:01 AM
  • Join Date: 08-11-2011
  • Referrals: 0

Feedback

Member Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View all feedbacks for roadtrip1098
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0

All times are GMT -5. The time now is 12:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use