E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   Angels Eyes just quit working? (http://forum.e46fanatics.com/showthread.php?t=378975)

Drexer 06-28-2006 09:14 PM

Angels Eyes just quit working?
 
I just noticed today that my angel eyes have quit working all together. (predator chromiums) They dont lite up unlocking, or even starting the car. We have had a serious amount of rain in the past week, the only thing that I can think is that water got in somewhere. Anyone ever have this problem or have an idea where I should start looking for the problem?

330i ZHP 06-28-2006 09:50 PM

Search for a bad ground first, water in the ballasts, or a power wire not getting power. Good luck, get a multi-meter, etc... DO NOT FORGET TO CHECK YOUR FUSES

Edison@JleviSW 06-28-2006 10:07 PM

Exactly, if both sides are out check your fuse, ground, + connection and taps. After that, there is the remote possibility that both of your ballasts got wet and shorted out.

Drexer 07-04-2006 12:29 PM

The gound connection and taps are all ok, the fuse was blown so I replaced it and it blew right away again so Im under the impression that the ballast are shorted out. Where can I get new ones?

Tyler@UniqueDesign 07-04-2006 01:25 PM

Quote:

Originally Posted by Drexer
The gound connection and taps are all ok, the fuse was blown so I replaced it and it blew right away again so Im under the impression that the ballast are shorted out. Where can I get new ones?

Contact your retailer......that should be the first person you ask for help with these problems too. Some of the vendors tend to get kindof finicky when problems get put on the forums because it makes them look bad - so if you contact them and give them a chance to handle it first, you almost always get better results.

JCsE46 07-04-2006 01:33 PM

^^^:werd: Contact your vendor where you purchased it from. From the sound of it, most likely the ballast have gotten wet and have shorted it out. You can buy ballast replacement thru Jlevi and/or Umnitza.

Cal 07-04-2006 08:05 PM

Quote:

Originally Posted by JCsE46
^^^:werd: Contact your vendor where you purchased it from. From the sound of it, most likely the ballast have gotten wet and have shorted it out. You can buy ballast replacement thru Jlevi and/or Umnitza.

He shouldn't have to "buy" them. Since Chromiums are advertised to have lifetime warranty, the vendor should replace them for free, including shipping of new ones AND a prepaid return label to mail back the defective parts. It shouldn't cost you a single penny.

Reedo302 07-04-2006 09:30 PM

Jiggle the connections. That worked for me when my remote operation stopped working during a meet. :thumbup:

Edison@JleviSW 07-04-2006 09:55 PM

Quote:

Originally Posted by Cal
He shouldn't have to "buy" them. Since Chromiums are advertised to have lifetime warranty, the vendor should replace them for free, including shipping of new ones AND a prepaid return label to mail back the defective parts. It shouldn't cost you a single penny.

Again which is why he should EMAIL!!!!!!!! his vendor first to get the problem figured out and get a replacement if necessary, UNDER the lifetime warranty.

Reedo302 07-04-2006 11:02 PM

:banghead:

Drexer 07-20-2006 09:14 PM

I got my new ballast and installed them and they now work again :excited: but they dont fade on and off with the interior lights when I lock and unlock the car. Is it because there is a blown fuse in the glove box?


All times are GMT -5. The time now is 12:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use