E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Suspension & Braking (http://forum.e46fanatics.com/forumdisplay.php?f=97)
-   -   Suspension Problems... (http://forum.e46fanatics.com/showthread.php?t=616675)

CurE 10-15-2008 08:10 PM

Suspension Problems...
 
Hey guys, recently i've been noticing some weird noises coming from my suspension. I currently have KW V2 on the car for about 6-7 months. Recently when i go over bumps or uneven roads the front makes loud clunking noises like its loose or about to fall off. When im coming out of my driveway the rear makes a squeaky noise. Do you guys have any ideas or suggestions. Thanks

Chris-TK 10-16-2008 01:36 AM

Have you used spacers up front to clear the KWs? What are the offsets of your front wheels? Are your RSMs properly tightened in the rear?

CurE 10-16-2008 07:51 AM

19X8 235/25/19 in the front...I have checked the RSM and its good...any other ideas...

TxZHP04 10-16-2008 08:08 AM

In the front, re-torque the sway bar end link nuts. Sounds like one might have backed off a tad. What end links are you running? Could also be a bad end link or possibly even a bad length adjustment.

In the rear, what sway bars, end links, and RTABs are you running? Have you inspected the area around the LR subframe mount for cracks? When you checked the RSMs, did you re-torque the nuts?

The reason I suggest re-torquing things instead of just using your fingers to see if they appear loose is because suspension loads can bind things up so that they feel tight until the suspension travels to a position that frees them up to rattle or squeak.

n2Bimmer 10-16-2008 10:51 AM

for the clunking in the front you need to put some time aside and remove your wheels and re tighten everything, regarding the squeking ive notived its pretty normall, it mostly body flexing, i have this also, however it was drastically improved after replacing everything in the front along with strut bars, lol, The rear is another monster, you have the RTAB's that are very common to go out, they wont look bad but they really are, also the end links. good luck.

FlzRider 10-18-2008 02:13 PM

I think I am having the same problem he described about his front suspension noise over uneven surfaces. My first thought is it has something to do with the sway bars, but I'm not sure if I should be replacing the endlinks or just tightening them. Also, do the two rubber sway bar bushings that mount it to the chassis of the car go bad often?

Anything else I should be checking for the correct torque?

FlzRider 10-18-2008 02:17 PM

Forgot to mention that I am running H&R RSS Coilovers.

Also, if an endlink were to be bad, do most replace with OEM or aftermarket? If so, which one?

reynaldo 10-18-2008 04:02 PM

I have this sounds only when i hit a bump. It soounds like it was loose in the rear. I replaced my rear shocks with Sachs OEM. I did not include the bottom washer in the shocks below the RSM. Is that the reason why? I tigthened the nuts though!

Chris-TK 10-18-2008 04:05 PM

Quote:

Originally Posted by reynaldo (Post 8710046)
I have this sounds only when i hit a bump. It soounds like it was loose in the rear. I replaced my rear shocks with Sachs OEM. I did not include the bottom washer in the shocks below the RSM. Is that the reason why? I tigthened the nuts though!

It's possible.

k3nmasters 10-21-2008 07:24 PM

I just put Koni Sports all around and I'm having this issue in the front. Takin it back to my friend for inspection and I'll let you know!


All times are GMT -5. The time now is 04:09 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use