E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   ///M3 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=65)
-   -   Dead battery, can't jump (http://forum.e46fanatics.com/showthread.php?t=750050)

ccarlozz 03-20-2010 10:25 AM

Dead battery, can't jump
 
2002 BMW M3 SMG. Battery died when I left lights on. Tried to jump with Honda Civic and all I get is flashing lights, windows lowering, clicking sounds when I try to start. Now windows are lowered and I can't get them back up. Suggestions?

budman 03-20-2010 10:49 AM

buy another battery

misterlau 03-20-2010 01:49 PM

when your hooked up to jump start, that should be enough to get your windows up.
don't actually crank it of course, just switch to the on position.

finding a car with a battery with a little more cranking power than a civic might help too.

Mstearnsy 03-20-2010 03:50 PM

A Civic will get it started eventually unless your battery is completely toast. Hook up the booster car and let the two cars sit together for 10 or 15 minutes. You can help the cause by giving the Civic some gas and RPMs to get the alternator contributing more. After 10 minutes crank the M3 and I'm sure it will start.

bimmerboi19 03-20-2010 03:53 PM

take the battery out and bring it some place to get it charged. If that doesn't work buy another battery.

opey 03-22-2010 10:19 PM

i think u just need to let it charge longer.. my battery was bad and would be completely dead after 3 days of not driving the. completely dead as in the door locks and lights wouldnt even work. i jumped it numerous times with a 2006 civic, no problem. it doesnt start right up though as soon as u connect it, gotta wait 2 or 3 minutes

gigyb 01-28-2013 08:35 AM

Quote:

Originally Posted by opey (Post 11505325)
i think u just need to let it charge longer.. my battery was bad and would be completely dead after 3 days of not driving the. completely dead as in the door locks and lights wouldnt even work. i jumped it numerous times with a 2006 civic, no problem. it doesnt start right up though as soon as u connect it, gotta wait 2 or 3 minutes

I tried the same with the Civic. Even after charging for 30 min and reving it didn't start the car. Now even the clicking sound has also gone.
Is it possible that the starter is dead or should I try changing the battery first.

///mteknikk 01-28-2013 10:40 AM

if the car cranks then the starter is fine. id start with a new battery seems like yours is completely toast. iv experienced before where ive had two jumpers at the shop trying to start the car but the battery was so toast it wouldnt even crank over

illestminimike 01-28-2013 10:49 AM

Quote:

Originally Posted by gigyb (Post 15102950)
I tried the same with the Civic. Even after charging for 30 min and reving it didn't start the car. Now even the clicking sound has also gone.
Is it possible that the starter is dead or should I try changing the battery first.

This thread is 3 years old. But get a new battery and let us know!

gigyb 01-28-2013 09:42 PM

Quote:

Originally Posted by illestminimike (Post 15103226)
This thread is 3 years old. But get a new battery and let us know!

Thanks
I got a new battery and it worked...

illestminimike 01-29-2013 12:20 AM

Quote:

Originally Posted by gigyb (Post 15105775)
Thanks
I got a new battery and it worked...

Great!


All times are GMT -5. The time now is 10:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use