E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Lighting Forum (http://forum.e46fanatics.com/forumdisplay.php?f=88)
-   -   Have you had problems with your EE LED tail lights? - please vote (http://forum.e46fanatics.com/showthread.php?t=750694)

Hartman 03-22-2010 07:36 PM

Have you had problems with your EE LED tail lights? - please vote
 
I am trying to collect some data on the failures of these tail lights. Anything from burnt out LEDs to wiring and LCM issues.

Thanks.

redrum0486 03-22-2010 08:21 PM

Yes, I've had issues. They flicker in the cold and the fit on them is atrocious. I do not understand why manufacturers can't make products that fit like OEM. Sure, they look pretty decent (from a distance) but the fitment gaps are horrible. And the wiring/interior trunk panels were disappointing as well.

Hugo780 03-22-2010 08:24 PM

a strip on my lights burnt out...also disappointed with the fitment

redrum0486 03-22-2010 08:25 PM

Fitment was the biggest issue for me. They're just as bad as DEPO products.

xi_ter 03-23-2010 12:03 AM

I was bothered by a bulb out warning in cold weather, I thought it was the EEs but it was due to a battery that needed to be replaced. So no problems with the EEs, just needed to sand a plastic piece down on install.

issacsierra06 03-23-2010 12:09 AM

strip of lights went out!!

GTB323 03-23-2010 01:12 AM

random lights went out. Also, one is a little slower then the other on lighting up

Solatso 03-23-2010 02:11 PM

I've only had mine for about a month but they're good so far. Fitment wasn't an issue for me, everything fit quite well. The only thing I didn't like was that the top screw with the white clip can easily be tightened down onto the circuit board to the point of breaking it. I had to be real careful when doing it so as to line it up properly to not make contact with the circuit board.

Marley78 03-23-2010 09:38 PM

for some reason when i step on the brakes when i start up the car, i get tail light out warnings on my dash, then when i turn on my headlights the warning lights go away. If i start up the car and not put my foot on the brake then i do not seem to get the warning lights. its weird.

chopstik 03-24-2010 12:29 AM

my passenger side went out completely
i removed them

Hartman 03-24-2010 07:52 PM

Looking to get at least 50 responses to the poll..

Brilliant 03-27-2010 12:33 AM

Went w/ OEM because I didn't want to F with them / have a ghetto looking car.

Hartman 03-28-2010 09:53 AM

Bump.

ryanwhite74115 03-30-2010 10:49 AM

On my third set...each time I have had 5-7 led's go out...Khoalty has been great but shipping them out every time (at $30 a pop) has cost me near what I paid for the tails originally in warranty work...

It's bullshit

Hartman 03-30-2010 06:27 PM

Need to get this moved to the General forum for more views...

Alex Pappas 03-30-2010 07:41 PM

Quote:

Originally Posted by Solatso (Post 11508565)
I've only had mine for about a month but they're good so far. Fitment wasn't an issue for me, everything fit quite well. The only thing I didn't like was that the top screw with the white clip can easily be tightened down onto the circuit board to the point of breaking it. I had to be real careful when doing it so as to line it up properly to not make contact with the circuit board.

We called the manufacturer on that same issue -they said break the two fangs off(I thought that was cheesy) and that they are redesigning the white piece. mine however are in and I feel that the gaps are too big and the trunk light panels are cheap and fit like crap. But they sure look awesome!

Solatso 03-31-2010 09:10 AM

Quote:

Originally Posted by Alex Pappas (Post 11542675)
We called the manufacturer on that same issue -they said break the two fangs off(I thought that was cheesy) and that they are redesigning the white piece. mine however are in and I feel that the gaps are too big and the trunk light panels are cheap and fit like crap. But they sure look awesome!

Yeah I forgot I did have to use my Dremmel to get the passenger side trunk light to "clip in", as the slot was off just ever so slightly, but I've done so much aftermarket stuff to cars that a little "shaving" seems normal to me now ;)

What gaps are to talking about?

n2Bimmer 03-31-2010 12:34 PM

Yes, the driver side blinker went out and came back after a few days. Almost every time i turn the car on i get a bulb out warning but no bulb out.

lllSupra 03-31-2010 12:43 PM

Who is the manufacturer? Also I've had mine for over a year and no probelms at all and the fitment looks just fine. The only problem I had was getting one the the trunk lights to get in correctly, but is was an easy fix

Alex Pappas 03-31-2010 09:39 PM

Quote:

Originally Posted by lllSupra (Post 11546109)
Who is the manufacturer? Also I've had mine for over a year and no probelms at all and the fitment looks just fine. The only problem I had was getting one the the trunk lights to get in correctly, but is was an easy fix

Eagle Eyes=mfr


All times are GMT -5. The time now is 08:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use