E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Driveline, Engine & DME Tuning (http://forum.e46fanatics.com/forumdisplay.php?f=98)
-   -   HELP!!! Car shuts off when i give it gas.... (http://forum.e46fanatics.com/showthread.php?t=871125)

volcom_da6 09-17-2011 09:17 PM

HELP!!! Car shuts off when i give it gas....
 
so recently my 03 325i has been acting up on me.the car turns on and stays on untill i put it in reverse or drive and give it gas it shuts off. I ran it low on gas one day and the next day it felt weird. It felt like it was miss-firing and sputtering. I thought it might the spark plugs since i hadn't changed them in over 8 months. so i changed the plugs out and its still the same. Also i just recently replaced the fuel filter about 4 months ago so i thinking it might just be clogged up? the car fight now has 96k miles on it. has anybody ever had this problem? im also thinking its my fuel pump.... please peps help me out i need to get my car running asap thanks for you help!

volcom_da6 09-18-2011 09:06 AM

Anybody ever had this problem?

Cengawer 09-18-2011 09:27 AM

I would say it's the fuel pump since you said you were running low on gas one day. When you have low gas, all the dirt n gunk in your tank sinks to the bottom and when you add gas on top of that to fill it up, all that gunk mixes therefore going into ur engine through the fuel pump. That would be my best guess.

volcom_da6 09-18-2011 07:44 PM

ok any idea where i could find one for a good price? will i have to drop the tank to get to it?

Cengawer 09-19-2011 08:16 PM

No they go around 30-50 bucks online. You don't need to drop the tank. It's a simple DIY. I've seen posts on how to do it

Cengawer 09-19-2011 08:17 PM

Just search ull find it

volcom_da6 09-20-2011 10:15 PM

Cool thanks bro!

volcom_da6 09-22-2011 06:01 PM

just replaced the fuel pump and its still giving me the same problem. the car still shakes and and shuts off asfter a few minutes. what could it be now? i wanna replace the fuel filter again but who knows if that would be the problem....

HyphyMovementZ 10-23-2011 06:47 PM

I had the same for me it was the camshaft position sensor

330i lover 11-21-2011 01:43 PM

Did this fix the issue? My car is having similar sputtering issues.

Custom3 11-21-2011 01:48 PM

any codes?

BMWUSMC3051 11-24-2011 12:46 AM

Check intake and exhaust hoses if they have a hole the engine will choke its self out exhaust hose is near washer resivor Intake obvious cost 2$ for a new hose hope this is the problem n this solves it for u did for me

330i lover 11-27-2011 09:27 PM

Resolution?

Rhudeboye 12-04-2011 09:36 PM

Yes, please check in on the status.

howie1971 12-13-2011 02:05 AM

I had this problem I replaced fuel pump yesterday and it seems to have fixed the problem (I ran out of fuel twice, it seems they are pretty sensitive) however I still have a vacuum leak, I have taken off the intake hoses and can not see anything perhaps I will try the exhaust hose.

330i lover 12-19-2011 06:45 AM

Yeah, I'm still having the issues. If my warranty doesnt cover it then i'll buy a pump from pelican parts. Did you have to replace anything else other than the fuel pump assembly? Fuel pump seal or a relay?

FERNY_M3 07-01-2014 02:59 PM

I have the same problem, now it got worse and even in D when i gently very gently press on the gas pedql and hold it the egine starts to gargol or choke idk but its sounds like its dieing and somtimes it turns off completely. Back then it was just when i was going in reverse now it happens somtimes when its in D. To add this only happens when the car is just turned on in the begining of every day only when its just warming up, aftr that trought the day f i turn it on or off put it in reverse or D its b just fine only does it when the car is turned on for the first time of the day.


All times are GMT -5. The time now is 12:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use