E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   Promblem starting my 330ci HELP! (http://forum.e46fanatics.com/showthread.php?t=881195)

radames15 10-20-2011 04:22 PM

Promblem starting my 330ci HELP!
 
Hi people I'm having a problem with my 2004 330ci aut(not zhp). When I try to turn on my car it starts but didn't turn on,other times it turn on and off very fast but after do the same thing like 5 times it starts normally and sometimes also the light from the transmission(at the left of the letter of P,R,N,D) went on. If I keep playing turn on and off the light comes off and I can drive the car normally. The codes are camshaft sensor,crankshaft sensor,air mass meter...crankshaft sensor and air mass meter are new. I think it's maybe the ECU...What do you think? I read somewhere I don't remember that the anti theft system send wrong codes and didn't start the car, that I have to change the ECU...

jasonbimmer 10-20-2011 04:26 PM

replace the sensors? why would it be the ECU?

ALPIN3 10-20-2011 04:45 PM

Possibly the fuel pump, but need to know more. It could be triggering the other codes since its "hiccuping" to get started right now.

radames15 10-20-2011 05:13 PM

the crankshaft sensor was replace...yes maybe it's the fuel pump thats my next step...i think its maybe the ecu because I have a vw with similar sympthons and was the ecu but I dont know my car has only 70k

radames15 10-25-2011 07:25 PM

Today I check the car and its a electrical problem..there is no current in sparks when the sympthon occurs...what do you think? Ecu?

chqj 10-25-2011 07:29 PM

What's the code you have? That's fun stuff. People will help you out.


All times are GMT -5. The time now is 12:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use