E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   E46 Convertible (http://forum.e46fanatics.com/forumdisplay.php?f=106)
-   -   Need help. seat belt light blink (http://forum.e46fanatics.com/showthread.php?t=891251)

2001bmw330cic 12-12-2011 02:18 PM

Need help. seat belt light blink
 
I just bought a 2004 BMW 325ci convertible with only 7,000 miles on it. The seat belt light blink on and off. If I put the key in the ignition and the seat belt light is sold, than it won't blink but it will blink after driving on and off. If it blink when I put in the key then it will blink on and off while I am driving also. Sometime it goes off for awhile while driving then goes on again blinking. Does anybody know what is wrong?

kib 12-12-2011 02:23 PM

some times the wires under the seat come loose have a look at the connections.

2001bmw330cic 12-12-2011 02:57 PM

I check into that already. No lose connection.

2001bmw330cic 12-12-2011 06:09 PM

Stop by auto to pull the code but no code show up.

Irishdb 12-12-2011 07:05 PM

Anything heavy on the passenger seat?

2001bmw330cic 12-12-2011 07:31 PM

Try it with and without anybody on the passenger side. If I put the key in and turn it on and if the seat belt light is on solid than the light will turn off after in put on the seat belt. But the light will blink after driving. It will brink on for a while than off for awhile and on again. Sometime I can drive for half an hour than it will goes on again. Sometime it stay on blinking and doesn't goes off.
If I turn on the Ignition and it blink right away it will blink for awhile on and off.

Rufffa 12-19-2011 08:53 AM

Got the same
 
I got the same problem.
I found the source of the problem- it`s a front seat switch.
It`s located under the driver`s and passenger`s seat.
It is resp. for lowering the headrest when You fold the seat.
Blinks when the sensor recognize the seat is fold down.

2001bmw330cic 12-20-2011 07:05 AM

Did you have to replaced the switch or just clean it?

Rufffa 12-20-2011 07:41 AM

It`s O.K. if You just clean it with spray that removes oxidation from electrical contacts. But first You have to take out the whole seat to get to it.

2001bmw330cic 12-20-2011 08:26 AM

Thanks, I'll try that over the holiday break.

BeaMerWorld 04-09-2013 06:37 PM

I am trying to do the same, is there a DIY or do you have photos when you did yours? I'm trying to figure out which one is the sensor that I need to clean.

Rufffa 04-10-2013 03:27 AM

Hi.
Actually You don`t have to take out the seat. It is really an easy fix and will take You no more than half an hour.
Check out my video and photos here:
https://dl.dropbox.com/u/89258837/20120615021.mp4
https://dl.dropbox.com/u/89258837/20120615237.jpg
https://dl.dropbox.com/u/89258837/20120615238.jpg

Just make sure the metal spring is not broken, than clean it and ... that`s it . You don`t need to erase any errors in the ecu.
Have fun!

jetad 04-10-2013 10:12 AM

I had this same problem for months. Did several scans but no error code came up. One day I was vacuuming the car and decided to just wriggle and shake the wires under the drivers seat. This solved the problem. Might work for you too before you disconnect anything.

BeaMerWorld 04-11-2013 09:54 PM

Rufffa check the video link, it's not working.


All times are GMT -5. The time now is 10:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use