E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   330Ci intermittent lack of power & hesitant starting...HELP! (http://forum.e46fanatics.com/showthread.php?t=897794)

robwallace 01-17-2012 03:05 PM

330Ci intermittent lack of power & hesitant starting...HELP!
 
Hi there, I have had my 2001 (51 UK plate) 330Ci for a couple of months and it has been great. Today however I was driving around as normal this morning, parked up for an hour then went back out to the car and it was hesitant to start which has never happened before. I noticed the EML light come on whilst I was attempting to start it. Once it did start, performance was down and it wasn't wanting to accelerate where normally it pulls like a train. I took it to my local garage and they put in on a scanner and it came back with nothing. I then drove it again for around 15 minutes this evening and initially it seemed fine, then again the lack of power started again. I had to park up for a couple of minutes to go into a shop and then after it was reluctant to start again and when it did it smelt like a burning smell. Just wondering if anyone has had this problem before and/or can shed any light on it, it's going back to the garage tomorrow but would like to have an idea beforehand!

Thank you! :-)

jasonbimmer 01-17-2012 05:01 PM

EML means theres something wrong with your drive-by-wire system ( throttle pedal, throttle body, idle control valve).

hummer 01-18-2012 11:02 AM

If the light came on, there should be a stored code. Maybe your mech just can't read it? The symptoms are similar to cam or crank position sensor failures which was intermittent on mine at first and then more severe. Could also be a fuel delivery issue with a clogged filter or failing fuel pump. My failing pump did not result in codes.

robwallace 01-18-2012 11:47 AM

Hi, thank you for the replies. I have had the car scanned again and it came back with a P0360 which indicates ignition coil? When the problems started, the car only went in to have the levels topped up and we checked it on the scanner and it had a P0340 and a P0160 which are cam position sensor and 02 sensor (rear one)? I don't know why it would be chucking up different codes every time. Will drive it again tonight and tomorrow and see what happens and have it scanned for a third time I guess, very odd!

markusmarkus 01-18-2012 02:44 PM

Ecu
 
Whenever a car is throwing a range of codes, two issues come to mind:
1. Is the code scanner capable of reading BMW-specific codes? If it is not it will give you seemingly unrelated codes when in fact the BMW-specific codes point to the problem.
2. Does the ECU's software require a reflash? This can happen when the electrical system isn't up to snuff. How old is the battery?

:str8pimpi

hummer 01-19-2012 11:22 AM

I believe if you were using a BMW specific reader, the bad coil/cylinder would be identified? Intake or exhaust sensor?


All times are GMT -5. The time now is 02:02 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use