E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Lighting Forum (http://forum.e46fanatics.com/forumdisplay.php?f=88)
-   -   2002 330i Headlight trouble (http://forum.e46fanatics.com/showthread.php?t=899928)

biMMer4.4i 01-27-2012 11:30 PM

2002 330i Headlight trouble
 
Bought the car a little over two weeks ago without a working xenon on the drivers side. Replaced the bulb (old one looked burned) but still didn't work. The following weekend the bulb was taken out again to look for loose connections. Still nothing. The car then sat for two days until I drove it today and the drivers side came on, and brighter worked too. It did look to be more of a yellow light than a xenon blue light though but still bright. The replacement bulb was identical to the original. Where am I going wrong? Any help is greatly appreciated.

Sent from my PC36100 using Bimmer

Toofpik 01-28-2012 12:06 AM

Does ur passenger light work fine? If so swap the bulbs and see what happens. Im no xenon expert but i did this when i had my old 330i and the passengers side was brighter and off color with both bulbs. A week later it just stopped working so i took it out and found out that water had got inside the balast and ruined it.

mpower009 09-30-2012 12:12 PM

Quote:

Originally Posted by Toofpik (Post 14025842)
Does ur passenger light work fine? If so swap the bulbs and see what happens. Im no xenon expert but i did this when i had my old 330i and the passengers side was brighter and off color with both bulbs. A week later it just stopped working so i took it out and found out that water had got inside the balast and ruined it.

Hello Toofpik, I believe my Xenon headlights have the same issue as your situation. Here is my car symthom, only passenger side doesn't work. So I replaced to brand new bulb and still it doesn't work. Is this mean the balast is shot?

Thanks!

98bimmer 09-30-2012 12:21 PM

If its not the bulb its either the ballast or igniter, if its the igniter you have to take your lights apart to replace them. I believe for the ballast you don't need to but don't quote me on that! Switch those around and that will answer your questions!

gavi 01-04-2014 05:41 PM

HI I have the same problem, have you guy got it solved? what was it?


All times are GMT -5. The time now is 11:04 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use