E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   325ci trouble over 4000rpm (http://forum.e46fanatics.com/showthread.php?t=907679)

Mc 007 03-06-2012 04:13 AM

325ci trouble over 4000rpm
 
hello,i have one trouble with my 325ci,over 4000-5000 rpm the yellow motor light switch on and the motor work 5 cilinders,stop and restart the motor works fine

pc control tells trouble on the 4 cilinder,change the ignition coil and the same...

can be the trouble the spark plug or the injection valve?

spark plugs are ngk and have 20 000km

thanks

dmax 03-06-2012 06:19 AM

It could be either the plug or the injector...you did change the coil boot with coil I assume? I'm not sure you can even get the coil without the boot, but I don't know.

Your plug might just be loose...

Mc 007 03-06-2012 08:22 AM

we have change today all 6 spark plugs,we have move the the injector and always the same on the 4 cilinder,trouble over 4000rpm

i have this
http://bmwfans.info/parts/catalog/E4...il_spark_plug/

Drewfus2101 03-06-2012 08:35 AM

I would try a compression test and a leak-down test. It sounds like there is something wrong with that cylinder head, valves, piston, etc.

Mc 007 03-06-2012 08:39 AM

compression test made 12,5-13 on all the cilinders...
the car works fine,no noises,goes perfect to 4000rpm in all the speeds

AquaRelliux 03-06-2012 09:21 AM

Maybe a longshot but since u checked everything else, hows your fuel filter and pump doing?

Solidjake 03-06-2012 09:27 AM

Any rattling with your DISA?

Mc 007 03-06-2012 09:29 AM

the fuel filter has maybe 20 000km,the pump is old 5 years(i change it 1 year after i buy the car),the disa has 2 years

straight_beamin 03-06-2012 09:31 AM

swap cyl 4 coil with cyl 5 if the misfire moves with the coil you have your answer. i had same prob, tried everything. turns out its a 60 dollar coil

Mc 007 03-06-2012 09:34 AM

i have try this solution,change coil,spark plug,injector...and always cilinder 4 error

maybe is a trouble with engine wiring harness
http://bmwfans.info/parts/catalog/E4...trical_system/

Drewfus2101 03-06-2012 10:14 AM

Was the compression test done correctly? Dry or wet? Hot or cold? Also, we have no idea what those numbers mean, so we can't really tell if those are within spec. But usually if all cylinders are within a few % of each other, thats a good sign.

Also, a leak down test is more accurate than a compression test, but the tester is much harder to find.

Mc 007 03-06-2012 10:28 AM

all 6 cilinders have the same compression

jasonbimmer 03-06-2012 11:48 AM

injector?

Mc 007 03-06-2012 11:52 AM

injectors are ok,tested,engine wiring tested and are ok,error code is P1349

tomorrow we can test the disa,we can put the disa of my fathers 320i on my 325

jasonbimmer 03-06-2012 11:54 AM

Quote:

Originally Posted by Mc 007 (Post 14154531)
injectors are ok,tested,engine wiring tested and are ok,error code is P1349

tomorrow we can test the disa,we can put the disa of my fathers 320i on my 325

usually with that specific kind of missfire/fuel cut off, its caused by compression.

Mc 007 03-06-2012 12:22 PM

compression is perfect,all 6 cilinders have the same compression

Mc 007 03-06-2012 12:48 PM

tomorrow we can control the disa...other is perfect

///Mostarac 03-06-2012 10:06 PM

neznam sta bi ti reko brate, nikad nisam cuo za ovo. maybe a vacuum leak? :dunno:

Mc 007 03-07-2012 03:34 AM

my fathers car is now in the mechanic station,we must test

Drewfus2101 03-07-2012 07:41 AM

Quote:

Originally Posted by Mc 007 (Post 14154641)
compression is perfect,all 6 cilinders have the same compression

This doesn't mean that there isn't a problem. A true leak-down tester can show you more specifically where a potential problem is. Google it. They are cheap.

Or...just keep throwing parts at it...


All times are GMT -5. The time now is 04:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use