E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   Car shakes VIGOROUSLY/NO ACCELERATION! (http://forum.e46fanatics.com/showthread.php?t=939113)

B3ZKONTROLU 08-17-2012 10:02 AM

Car shakes VIGOROUSLY/NO ACCELERATION!
 
Good day to all!!

I had my oil changed yesterday, picked up the car and drove it for about 1.5 hours. Came home, started the car and bang... the car started shaking vigorously and idling below 1000 rpm. It shook like little jolts. I tunred it off and back on same thing, and the problem kept going. SES light came on. Went back to the guy who changed the oil, he read code P0302. Saying that the second coil is misfiring. Mind you now, I used to have a slight jerk/hesitation around 2500 RPM. The guy said that it's the same problem that has escalated. Is it? Also, is this a simple coil swap or could it be another issue? :banghead:

Please help,

Thank you!

Mango 08-17-2012 10:07 AM

Swap the coil, clear the code, and see if the misfire changes cylinders.

And above all, stop taking your car to get serviced. Do it your friggin' self.

2003silver330i 08-17-2012 10:15 AM

I see more and more threads about cars coming back from service stations and dealerships with issues. Man these cars are finicky. If you just brush a connector, hit a bump, or look at it wrong an issue creeps up after the visit.

Mango 08-17-2012 10:17 AM

Quote:

Originally Posted by 2003silver330i (Post 14659574)
I see more and more threads about cars coming back from service stations and dealerships with issues. Man these cars are finicky. If you just brush a connector, hit a bump, or look at it wrong an issue creeps up after the visit.

Maintaining it well ensures no problems like these ever arise.

lsteg 08-17-2012 10:22 AM

Quote:

Originally Posted by B3ZKONTROLU (Post 14659540)
Good day to all!!

I had my oil changed yesterday, picked up the car and drove it for about 1.5 hours. Came home, started the car and bang... the car started shaking vigorously and idling below 1000 rpm. It shook like little jolts. I tunred it off and back on same thing, and the problem kept going. SES light came on. Went back to the guy who changed the oil, he read code P0302. Saying that the second coil is misfiring. Mind you now, I used to have a slight jerk/hesitation around 2500 RPM. The guy said that it's the same problem that has escalated. Is it? Also, is this a simple coil swap or could it be another issue? :banghead:

Please help,

Thank you!


If you got the car back in worse shape then you gave it to the mechanic then I would make him repair the issue.


On the other hand....since he did such a stellar job before I suggest just taking this on yourself. There's plenty of knowledge and DIY's here to get you through changing the coil.

B3ZKONTROLU 08-17-2012 11:06 AM

Yea, I am on my way to pick up the coil right now. I don't want him to touch my car ever again. I'll get the pleasure out of fixing it myself. :thumbsup:


All times are GMT -5. The time now is 11:53 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use