E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   330D turbo disturbing accel. (http://forum.e46fanatics.com/showthread.php?t=940543)

Sk1r3x 08-24-2012 10:47 AM

330D turbo disturbing accel.
 
Hi guys, I've got some turbo problem. Four months ago my mechanic forgot to lock tape on connection of intercooler and air hose to manifold. From this moment I feel turbo is knocking when starts to blow ... I found out that actuator is jumping up and down from 1800 rpm during whole acceleration, not only smoothly opens like it's normal ... BUT ! This stops happen after I disconnect MAF , actuator is pulling smoothly and there is no turbo lagging anymore.

Things I tried : cleaned MAF , switched converters between TURBO-EGR , new MAP, closed EGR.

Diag through INPA looks fine , no overboost spotted, MAF values also good...

This is my car , check it after 13th second , actuator pulling fine without maf connected
http://www.youtube.com/watch?v=MBim7uJEvxU&feature=plcp

... and this is actuator jumping after boost 1800rpm wit MAF connected
http://www.youtube.com/watch?v=V5bKq2WrDlE&feature=plcp

sorry for grammar :) .... any ideas ?

NE1L 08-24-2012 11:47 AM

If disconnecting the MAF fixes the problem, replace the MAF with a new one. Cleaning the MAF is always the answer, it would appear that it needs replaced.

Sk1r3x 08-24-2012 11:54 AM

I have tried another MAF , but problem was exactly same ... :( , there was no difference, I only believe that another MAF was exactly same broken ?

My friend has 320D 100kW , he has 100% good MAF and I try to get it in my car after he comes back from holiday ...

This is what happens when everything is good , smooth move of actuator and also different move when shifting gears . This is his actuator
In 10 sec 1800rpm 3rd gear - smooth and nice move
http://www.youtube.com/watch?v=smZbGPeBaVo&feature=plcp

trive2 08-24-2012 07:14 PM

You sure you're testing with identical MAF's? The 320d MAF shouldn't be the same as the 330D MAF?

Sk1r3x 08-25-2012 03:25 AM

MAF in 320D 100kW is identical with 330D 135kW , but already not identical with 150kW. A have 135kW , they are same in EU3 norm so no DDE flashing needed.

But there is still no one who have met with this kind of fault ? Or I'm the first on this planet who can use camera to watch actuator during ride ? :facepalm:

Consider that MAF is not solution, without MAP connected a values in actual air pressure are mostly higher about 0,2 - 0,3 bar in all modes of ride.
With MAF connected a values are higher only about 0,05bar and after turbo boost in 1800 rpm the only gap is max. 0,15 bar ...

Someone thinks that after boost , actuator is pulled back because turbo makes overboost ? ... There's no way

choxor 08-25-2012 04:00 AM

We don't have the turbo diesel e46 in the states and you'll find most of us on this forum are from the US. You'll probably get a quicker response posting on the e46zone.com forums.

Sk1r3x 08-25-2012 04:11 AM

sorry , didn't know it , already on e46zone , thanks ... someone can delete thread

choxor 08-25-2012 04:22 AM

Quote:

Originally Posted by Sk1r3x (Post 14679135)
sorry , didn't know it , already on e46zone , thanks ... someone can delete thread

Na, no need to delete it. It's a good thread. If you figure out what's going on it would be cool to post it here, too. Someone else might have a similar problem and search the forums for it. :thumbsup:


All times are GMT -5. The time now is 12:07 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use