E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Forced Induction Forum Sponsored by Active Autowerke (http://forum.e46fanatics.com/forumdisplay.php?f=41)
-   -   Dsc problem (http://forum.e46fanatics.com/showthread.php?t=942127)

bluba 09-01-2012 11:00 AM

Dsc problem
 
Got in the car and turned on and dsc light was on. Had no power etc at first. Turned car off and restarted....dsc light was off but still have no power...what I mean by no power is like when dsc is on all the time. Can anyone help me on where to look for problem or what is wrong? Could HPF kit have anything to do with it. Thanks

Ky///m3 09-01-2012 11:03 AM

In for diagnosis

SweTurbo 09-01-2012 11:30 AM

Call HPF :) If you've paid for a kit then you've also paid for customer service which HPF is awesome at :)

InDiGlOM3 09-01-2012 11:39 AM

Tps.....your max rev is 4000k

Sent from my PG86100 using Bimmer App

InDiGlOM3 09-01-2012 11:39 AM

Do you have the eml light on?

Sent from my PG86100 using Bimmer App

bluba 09-01-2012 11:45 AM

Quote:

Originally Posted by InDiGlOM3 (Post 14697662)
Tps.....your max rev is 4000k

Sent from my PG86100 using Bimmer App

At first the car won't even rev at all...I will check on rpm

bluba 09-01-2012 11:51 AM

Quote:

Originally Posted by InDiGlOM3 (Post 14697665)
Do you have the eml light on?

Sent from my PG86100 using Bimmer App

Just the dsc light was on

bluba 09-01-2012 11:52 AM

Quote:

Originally Posted by InDiGlOM3 (Post 14697662)
Tps.....your max rev is 4000k

Sent from my PG86100 using Bimmer App

Car goes well over 4000 rpms

bluba 09-01-2012 12:02 PM

Well let car sit for 40 minutes while a ran in store.... Working fine now so I don't know if car would not go over 4000rmp before but all is well now. ***128563;

Forcefed M3 09-01-2012 05:19 PM

Quote:

Originally Posted by InDiGlOM3 (Post 14697662)
Tps.....your max rev is 4000k

Sent from my PG86100 using Bimmer App

That's what I was thinking. Mine had the same issues!

bluba 09-01-2012 06:22 PM

Ok I have no idea what this means than!

bluba 09-01-2012 06:48 PM

Quote:

Originally Posted by bluba (Post 14698320)
Ok I have no idea what this means than!

Never mind I researched it, but there is three of tps?

AirFrcd 09-01-2012 07:11 PM

Could it be a CPS?

Forcefed M3 09-01-2012 08:20 PM

Quote:

Originally Posted by bluba (Post 14698372)
Never mind I researched it, but there is three of tps?

Most often it is the one on the throttle bodies. Super easy to change out, about $80.00.

bluba 09-03-2012 03:53 PM

Thanks for help. I plugged in my OBD ll reader and P0121 code or BMW 121 came up and it showed TPS/ pedal position sensor so it must be the sensor at the pedal!!

bluba 09-04-2012 08:18 AM

Ok BMW is telling me I have to buy the whole pedal assembly for sensor ($150). Has anyone just bought the sensor only and where

Commanderwiggin 09-04-2012 08:19 AM

Quote:

Originally Posted by bluba (Post 14703191)
Ok BMW is telling me I have to buy the whole pedal assembly for sensor ($150). Has anyone just bought the sensor only and where

Believe you need the whole pedal assembly...unfortunately.

BDUB328I 09-04-2012 02:56 PM

i have my pedal out of the car if i can send you any pics to help out let me know


All times are GMT -5. The time now is 10:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use