E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   Loosing Power? (http://forum.e46fanatics.com/showthread.php?t=945524)

apmanzojr 09-19-2012 11:55 AM

Loosing Power?
 
Hi Guys

I was driving my car today 1999 323i E46 auto and I have noticed that when I am stepping on the accelator that especially when it passed the second gear that I felt like I have no torque power it drives okay and the engine seems like there is nothing work however but it felt like something is not right.. I noticed also that when I am accelerating the MPG meter is always high and when I am slowing down and even I letting my foot off the gas I noticed that the MPG meter is still going up especially my tachometer is going to normal RPM and the MPG even it goes up again up to 20 and goes back down to zero.

Hi Guys
I was driving my car today 1999 323i E46 auto and I have noticed that when I am stepping on the accelator that especially when it passed the second gear that I felt like I have no torque power it drives okay and the engine seems like there is nothing work however but it felt like something is not right.. I noticed also that when I am accelerating the MPG meter is always high and when I am slowing down and even I letting my foot off the gas I noticed that the MPG meter is still going up especially my tachometer is going to normal RPM and the MPG even it goes up again up to 20 and goes back down to zero.

Sorry if it is confusing it's my first time that I have experience this with this car and it's hard to explain. I did changed the spark plugs last week and use bosch I have learned that it should be NGK I am thinking of changing it back to NGK this week. I wonder if this is the cause of it any ideas what is ist?


but there were no check engine light in my car


Thanks

Mctwist77 09-19-2012 12:11 PM

If you just got the car I would recommend doing all the basic maintenance first then you can look to see where you are getting the bogging down.

Does this happen when the AC is off or just when its on?

apmanzojr 09-19-2012 01:14 PM

Cool thanks, I did some maintenance on it I did changed the oil, filters, air filtes and spar plugs it was running okay yesterday, I just noticed it today when I am driving it, I did talked to one of the person in Pelican Parts and he told me that it could be the crankshaft sensor is failing I don't have any check engine line on and one think I noticed is when I am accelerating and when I am letting go of the gas pedal, the MPG meter is still on high it goes down and goes back up again up to 20 even the I don't have my foot on the pedal and it goes down again it ist probably crankshaft issue?


All times are GMT -5. The time now is 07:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use