E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Bavarian Soundwerks' Mobile Electronics Forum (http://forum.e46fanatics.com/forumdisplay.php?f=22)
-   -   2003 325xi Stereo not working/ Electrical problems (http://forum.e46fanatics.com/showthread.php?t=948522)

cocolo9uno 10-03-2012 07:07 PM

2003 325xi Stereo not working/ Electrical problems
 
I bought my 325xi a couple of weeks ago knowing that the stereo didnt turn on. BMW told the dealer that they didnt know what the problem was and to take it to a stereo specialist to see if it could be repaired or if it had to be replaced. I took it to a well known car audio chain here in Charlotte called Freemans Car Stereo and they looked at it and said it was missing a fuse in the first place but when they put one in it still didnt turn on so i would need a new stereo but they went ahead and left the fuse in it. So i said id be back probably later in the week.

After about 10 min of driving home i noticed my turn signals, dash lights, and sunroof stopped working. And also the "warning beep" when u open the door wont stop until about 30 seconds after u close the door. Basically electrical problems. I took it back and told them what happened and they said thers no reason why that fuse should affect the other electrical in the car like that but that theyll go ahead and remove the fuse. They did and evrything went back to normal. Apparently i have a HUGE and EXPENSIVE electrical problem according to them....
Does anyone have any idea what the problem could be or has anyone experienced anything similar??? :banghead:

scottjoh 10-03-2012 07:57 PM

Search for k-bus and follow the repair procedure outlined by Seth at jbeurotech.

jgold47 10-03-2012 08:34 PM

Yup. Your radio is ****ed up. Which is ****ing up your k bus. Which means your stereo guys are ****ing idiots. Get a new stereo and try again. The kbus cascading failure is ****ing stupid, but as soon as you fix it, yank the battery, it's 100%

benzovs 10-04-2012 12:24 AM

Exactly ^

cocolo9uno 10-04-2012 02:09 PM

Quote:

Originally Posted by jgold47 (Post 14785786)
Yup. Your radio is ****ed up. Which is ****ing up your k bus. Which means your stereo guys are ****ing idiots. Get a new stereo and try again. The kbus cascading failure is ****ing stupid, but as soon as you fix it, yank the battery, it's 100%

"Yank" the battery??? Thanks btw

cocolo9uno 10-05-2012 07:46 PM

Got it figured out. They put a new stereo in and just rewired it so that its power supply is coming from the ignition. Problem fixed. Only drawback is that i cant have the radio on in ACC. Car has to be on now which i can live with.


All times are GMT -5. The time now is 01:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use