E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   Cold morning stall (Narrowed down...maybe?) (http://forum.e46fanatics.com/showthread.php?t=949239)

killerbee3 10-07-2012 09:56 PM

Cold morning stall (Narrowed down...maybe?)
 
I posted a thread last year about my car stalling on cold mornings. I replaced a few things trying to fix it and came up with no results. I replaced the fuel filter, vanos seals, cleaned the ICV and I read a few maintainence records that show the previous owner had both cam position sensors and alternator replaced. I never did replace the secondary air hose which I was told to do. I am gonna do that next but I was wondering if anyone else knew what else that it could be since I narrowed it down a bit. I was thinking it could be more fuel related? like the pump but it makes a noise indicating that it is functional when the key is in the on position.

I'm just really annoyed right now since I also have to replace my power steering pump and rack... a second time. Well rack is a first.

I appreciate dearly any input on this situation that could lead me in the right direction...I've been searching all day :(

jfoj 10-07-2012 10:01 PM

Suggest you read the first link below in my signature.

SAP vacuum lines and DISA are very likely culprits.

killerbee3 10-07-2012 11:33 PM

Thank you! Very nice thread you made

dmax 10-08-2012 06:12 AM

+1 on sap. Check both the hose from the pump (for a hole and/or for squishiness) and check that the vac line is intact too.

Also, look in the valve to see if it's clogged from decomposed hose plugging it up. I had this issue...and it caused my car to stall on cold start.


All times are GMT -5. The time now is 10:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use