E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   Limp mode from MAF (http://forum.e46fanatics.com/showthread.php?t=951425)

Weste46 10-19-2012 06:50 PM

Limp mode from MAF
My car always goes into limp mode after a few seconds of movement, not just when idling however. When I unplug the MAF sensor the limp mode never returns. I got a new MAF sensor from VDO with no improvement. Any thoughts?

Sent from my DROID RAZR MAXX

Weste46 10-19-2012 06:57 PM

I should say it takes about 20 seconds for it to jump into limp mode, and never does at idle with MAF plugged in. When unplugged, car starts rough (as it always does with no MAF) but never gets a limp mode error, just an SES.

Sent from my DROID RAZR MAXX

Weste46 10-20-2012 12:31 PM

Anybody? My problem has slowly crept up to being worse and worse. I got limp mode once a month when I first bought it, and a restart would solve my issue. Now its gotten to he every start. Dealership isn't opened on the weekend, so I'll get generic Autozone codes pulled today. I'm thinking DME..

Sent from my DROID RAZR MAXX

RayPooley 10-20-2012 12:57 PM

Immediate thought is that it wasn't even/solely a MAF problem in the first place. Otherwise the new MAF would have fixed it. Right? Possibly something downstream of the MAF. Intake camshaft sensor? What made you think MAF? You got no fault codes? You need fault codes. You can't really just guess these things. They are all inter related.

Weste46 10-20-2012 02:02 PM

What made me think mass air flow sensor was that when it is unplugged it fixes the problem. No more limp mode. However now my ECU will not connect with any type of scanner tool.. I had the same guy at autozone do it for me and I did it myself and neither of us could get it to work any longer. Its most likely not the wiring harness because it doesn't happen from bumps. Either way I cannot scan my codes now so I need to figure out what is wrong..

Sent from my DROID RAZR MAXX

Weste46 10-20-2012 02:24 PM

I haven't been able to pull fault codes for some time now. I guessed MAF sensor because it didn't go into limp mode when it was unplugged. Likely assumption if you can't get codes.. before frequent limp mode I could pull codes. I have replaced the ICV (I had a p1500 code) and the MAF. All intake boots are good, TB plate moves well, although has resistance on it, but never gets caught up or stuck. I assumed this was normal.

So, something that puts you in limp mode AND stops you from pulling diagnostic codes. I'm thinking ECU... DME problem?

Sent from my DROID RAZR MAXX

Weste46 10-20-2012 04:07 PM

Taking it to the stealership soon, gonna see if they can pull the codes, and if they can't, see if they know why.

Sent from my DROID RAZR MAXX

Weste46 10-25-2012 10:16 AM

Bump for this, Stealership wants way to much to run diagnostics.. I doubt they'll even be able to.

Nobody knows what may be causing all of this? It all started at the same time.

Sent from my DROID RAZR MAXX

Weste46 10-25-2012 11:33 AM

My OBD II port gives power to reader tools, but does not communicate. I tried to test the pins however, and could not get a 12v power lead? Can someone confirm where I should be checking?

Sent from my DROID RAZR MAXX

Guest021715 10-25-2012 12:56 PM

Did you make sure the key is in position 2?

If you had the $30 BMW Scanner, you'd need nobody else but yourself to get the codes. They wouldn't be meaningless generic codes either.

Weste46 10-26-2012 12:01 PM

No Actron scanners will work. I can't get an appointment with the dealership that actually works around my schedule.. are there no other shops other than dealerships that can read specific codes?
Are there any Indy shops that can simply clear adaptations for me, you think?

Sent from my DROID RAZR MAXX

jfoj 10-26-2012 12:23 PM

1 Attachment(s)
You show your car as a 2001, however, you probably have a large round connector under the hood, if you do, you will need the round to standard ODB adapter cable to read your codes while connected under the hood.

Also check the terminals in the MAF connector and make sure they are not damaged and are tight.

If you have a CEL on, get your codes read and post back here for comment. Check to see if you have the large round under hood connector as well.

Weste46 10-26-2012 01:12 PM

My vehicle was produced post-OBD II change, it only has the 16 pin under the dash. The codes cannot be pulled, I don't know why.. pin 16 has power but it does not connect. I've fiddled around with the key a lot to no avail. I now realize that it takes a minute to go into limp mode because the car starts on an open loop system, not utilizing most of the sensors. Once they are in spec with where they should be, the ECU turns to closed loop, and begins using these sensors. That must be where the limp mode comes from, as when the MAF is unplugged, it is in an open loop the entire time, not just partially. One of the sensors must be off, or my DME is jacked up (which would explain the OBD II mess-up). The only thing is, the ICV and MAF are new, the TP sensors would make it go into limp mode even when in open loop, as would the wheel sensors, and I don't know what other sensors are activated only in closed loop.

Does anyone have a list of closed-loop only sensors? That would be wonderful. If the CSP sensors are included, specifically the exhaust side, then I know where I'll start. That one leaks oil and the o-ring has been replaced (unless the oil is from the nearby VANOS unit, and I'm looking at it wrong).

Sent from my DROID RAZR MAXX

RayPooley 10-26-2012 01:29 PM


Originally Posted by Weste46 (Post 14849115)
No Actron scanners will work. I can't get an appointment with the dealership that actually works around my schedule.. are there no other shops other than dealerships that can read specific codes?
Are there any Indy shops that can simply clear adaptations for me, you think?

Sent from my DROID RAZR MAXX

Any good indie will be able to read your fault codes. Do you not have any kind of auto callout membership like we have in the UK eg: AA or Greenflag etc? They can read your fault codes. Might even be able to fix it.

flashmeow 10-26-2012 05:12 PM


I don't think your problem is from a BAD MAF. Unplugging the MAF just default the engine to run on its pre-determined fuel/air maps. When the MAF is plugged in, your DME/ECU is using realtime data (air flow) to calculate the fuel/air mixture.
This is the reason why your car doesn't go into limp mode with the MAF unplugged.

VDO/Siemen is the OE supplier to BMW for its MAF. Therefore, the likley hood that your new MAF is also defective is unlikely.

Like everyone said, just get a diagnostic because solving this complex problem will be difficult w/o a scanning tool. BTW..autozone offer free SES/CEL scanner assuming you have an OBD-2 port and not the older BMW DLA port (cicular plug located in the engine bay)

I hope this helps, good luck!!

Weste46 10-27-2012 10:00 AM

I think my posts might be too long, but most of you are not reading them thoroughly. I realize the open loop ECU mapping is the reason for the limp mode not appearing. I also believe the MAF is fine. My problem now is finding out WHICH sensor or wiring harness section is defective, but I can't figure it out because of my MAIN problem, which is absolutely NO connection to my OBD system.

Sent from my DROID RAZR MAXX

Weste46 11-12-2012 03:14 PM

Update: still not wanting to spend all that money to have it scanned, but have noticed something new. When in limp mode, MAF connected of course, I get a rough idle. Never when in open loop. So, it has to be a sensor that is not used in open loop, that would give a SLIGHT bouncing idle. It gets worse and worse subtly when I do notice the idle is bouncing.

Someone? It can't be that expensive to fix, so I don't want to spend 100 bucks scanning it, when the sensor will most likely cost less than that to replace.

Sent from my DROID RAZR MAXX

jdstrickland 11-12-2012 03:22 PM

Have you given any thought to the idea that the main computer is toast?

Your car runs poorly, it MUST BE THROWING CODES. It has to be. If you cannot pull codes, then at least one of them is that the computer doesn't work, and if there is no computer then the car should be expected to run like crap.

Your car is a 2001, so it will talk to through the Data Link Connector to a pc running the diagnostic software. Your car _should_ communicate through the OBD II data port in the left side footwell, but you have said that it does not. You confuse me on this point though, you said it powers the scan tool, but then you said you can't find 12V. I'm confused at how the scan tool can be powered without 12V. You MUST set the ignition to RUN (Position II) to get codes out.

jdstrickland 11-12-2012 03:33 PM

A MAF sensor costs more than the scan.

The MAF should not invoke Limp Mode. I suppose it could, but I cannot form the logic in my head to support such a thing. A MAF is not a required part for simple engine operations. It is required for complex engine operations, and the complex operations would be needed to conform to emissions requirtements. The MAF reports the air density, and the information is used to modulate the fuel so that the proper air/fuel ratio of 14.7:1 is acheived and maintained. The O2 Sensors are used to fine tune the fuel mixture, and the inability of the O2s to fine tune the mixture is reported as RICH, LEAN, or MALFUNCTION. There are codes (FUEL TRIM and FUEL CONTROL, the latter being BMW codes in the P1 family) for these conditions. My car had a bad MAF, but it did not invoke Limp Mode. Indeed, my car had a bad MAF, and were it not for a host of other codes that appeared repeatedly, I would not have known there was anything wrong with the car. It ran perfectly, except that the Check Engi8ne light kept coming on.

Weste46 11-12-2012 03:41 PM

The codes CAN be pulled now, I fixed that issue, sorry for not saying that. The only code that appears is a P1500, which is ICV stuck open. the ICV is new however. The MAF has been replaced, and I know is not the problem, im not sure how to change the title of the thread.. it's not the ICV or MAF, but seems to have to do with both, and is NOT used while in open loop mode.


Sent from my DROID RAZR MAXX

All times are GMT -5. The time now is 11:55 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.