E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Lighting Forum (http://forum.e46fanatics.com/forumdisplay.php?f=88)
-   -   Passenger xenon sometimes doesn't turn on, makes clicking sound (Video) (http://forum.e46fanatics.com/showthread.php?t=955699)

COBYATCH 11-13-2012 12:52 AM

Passenger xenon sometimes doesn't turn on, makes clicking sound (Video)
 
Hey guys,

The passenger xenon on my 03 325i sometimes doesn't turn on, and until now I realized that it makes a clicking noise when it happens. Does this sound indicate whether it is a ballast or ignitor problem? I'm pretty sure it's not the bulbs because this was happening even after I replaced both sides with Phillips 85122 more than half a year ago, but I will try and swap them back and forth between sides to make sure. I've attached a video to show you the sound. You can hear it when the turn signal light comes on, but the xenon doesn't.

Also, sometimes my driver side xenon flickers. Where should I begin in finding the problem?

http://www.youtube.com/watch?v=fS0JFQcv7bc&

-Coby

Solidjake 11-13-2012 05:19 AM

Sounds rings a bell but I can't be sure. It is probably the ballast or ignitor as you stated. Check the wiring for from the ballast to the bulb.

COBYATCH 11-21-2012 03:06 AM

Just thought I'd give an update on the situation:

Turns out it was the bulbs lol. I spent about an hour switching the ballasts and the problem stayed on their sides (Flickering on the left, sometimes doesn't turn on for the right). I was too lazy to take them all out and try switching the ignitor, so I thought why not, and switched the bulbs. The problems stayed with the bulbs and the left one started to sometimes not turn on. Just a reminder for anyone that doesn't want to waste an hour, and if you're like me, lose a screw into the engine bay.

Cyanide72 11-21-2012 10:22 AM

Sorry for the totally unrelated question, but why no angel eye around the xenon?

COBYATCH 11-22-2012 09:55 AM

Quote:

Originally Posted by Cyanide72 (Post 14917229)
Sorry for the totally unrelated question, but why no angel eye around the xenon?

I liked the look at first haha. I put them back on since the video.


Looks like I spoke too soon. Now the left side and the right side are still giving me this problem, though it occurs on the left side more. I'll try switching ignitors and see where that gets me.


All times are GMT -5. The time now is 06:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use