E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Bavarian Soundwerks' Mobile Electronics Forum (http://forum.e46fanatics.com/forumdisplay.php?f=22)
-   -   2001 325i radio problems (http://forum.e46fanatics.com/showthread.php?t=955712)

vsphantom 11-13-2012 01:11 AM

2001 325i radio problems
 
1 Attachment(s)
so i have a buisness radio and it is malfunctioning
sometimes i get only static when i turn it on
sometimes i get nothing just silent
and sometimes it gets only 1 station across the frequency band
IE
KLOS is 95.5 right but when i switch over to 102.7 which is kiss fm it still plays 95.5 music same thing with 88.8 92.7 etc
i tried adjusting the antenna cable behind the head unit which gives me back some stations but it goes away when i turn on the car

thanks

vsphantom 11-18-2012 05:10 AM

Bump

scottjoh 11-18-2012 11:13 AM

Since you are picking up the same station in multiple places it sounds like the radio is not tuning right (bad radio). Just bad reception could be a FZV antenna amplifier problem or antenna problem. I see you're in LA too. I have spare FZV that I use for testing as well as an extra business CD radio.

vsphantom 11-19-2012 12:39 AM

Quote:

Originally Posted by scottjoh (Post 14909839)
Since you are picking up the same station in multiple places it sounds like the radio is not tuning right (bad radio). Just bad reception could be a FZV antenna amplifier problem or antenna problem. I see you're in LA too. I have spare FZV that I use for testing as well as an extra business CD radio.

what does the fzv stand fo?

markusmarkus 11-19-2012 09:01 AM

Try this procedure:
Disconnect both leads from the battery.
Short the leads together for approximately 10 minutes.
Reconnect the battery leads.
By the way this is an approved BMW procedure.


All times are GMT -5. The time now is 08:13 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use