E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   power steering problem (http://forum.e46fanatics.com/showthread.php?t=958450)

brodaiga 11-29-2012 02:02 PM

power steering problem
 
all four hoses, canister and pump replaced 30 days ago. Along with rebuilt rack. Pump put in was also a rebuilt oem pump. Problem is, when you turn the wheel I hear a loud whining sound and the fluid does not seem to be circulating looking at the open reservoir. None of the hoses are compressed. Car has power steering and drives ok, it is that loud whine when you turn the steering wheel a little bit and lack of fluid circulation. Is it a bad pump?

WDE46 11-29-2012 02:31 PM

Quote:

Originally Posted by brodaiga (Post 14937718)
all four hoses, canister and pump replaced 30 days ago. Along with rebuilt rack. Pump put in was also a rebuilt oem pump. Problem is, when you turn the wheel I hear a loud whining sound and the fluid does not seem to be circulating looking at the open reservoir. None of the hoses are compressed. Car has power steering and drives ok, it is that loud whine when you turn the steering wheel a little bit and lack of fluid circulation. Is it a bad pump?

If it's still under a parts warranty I would trade it out immediately just in case.


All times are GMT -5. The time now is 12:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use