E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Bavarian Soundwerks' Mobile Electronics Forum (http://forum.e46fanatics.com/forumdisplay.php?f=22)
-   -   Why are my speakers on one side of my bmw e46 only working?? (http://forum.e46fanatics.com/showthread.php?t=960564)

dan19 12-13-2012 03:42 AM

Why are my speakers on one side of my bmw e46 only working??
 
Why are my speakers on one side of my bmw e46 only working??

PH03NIX46 12-13-2012 04:10 AM

http://www.youtube.com/watch?v=cR2XilcGYOo

Blast that and blow them back into operating conditions.

scarede46er 12-13-2012 05:42 AM

Amp. Done.

ddombrowski 12-13-2012 06:51 AM

Yeah the trunk amp is going out. Mine does the same thing.

330iPilot 12-13-2012 08:16 AM

Could also be intermittent connections. It may be worth disconnecting plugs and spraying w/contact cleaner to make sure.

Brinkley 12-13-2012 08:27 AM

Indeed. Can't hurt to look into connections before buying new amp.

ryannel2003 12-13-2012 09:56 AM

I would assume you checked the balance control on your headunit first? If so, I'd also be looking into amp.

scarede46er 12-13-2012 10:17 AM

Too bad you are in Aussie land. Else I have/had a spare amp. :)

DBrown 12-13-2012 07:32 PM

If you have the hk setup like mine you have protection circuits, so if there is a short, ie blown speaker or loses wire or metal touching the positive lead it will kick into protection mode and disable some speakers, happened to me when i installed after market speakers. They worked fine and a few weeks later the leads at the back of the speakers were apparently touching the door metal, vibration made them wear through the paint a little and caused a short and before i knew it, only had half my speakers working. Check connections and wires for shorts, check for really blown speakers, cause if they are just a little blown doubt it would cause a serious enough short to kick in to protection mode. If no shorts then looks like its your amp. Maybe deck, but i don't know too much on these bmw decks so i wouldn't quote me on that.

dan19 12-13-2012 08:50 PM

ah k thanks everyone i installed a sub and amp like a year ago and brought it back to place where i had it installed and they tested the speakers with some tool and said there working and then he said it could be some box in boot that could be stuffed but how can i check ?


All times are GMT -5. The time now is 02:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use