E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Driveline, Engine & DME Tuning (http://forum.e46fanatics.com/forumdisplay.php?f=98)
-   -   EML Light & 4 Codes (http://forum.e46fanatics.com/showthread.php?t=960687)

Weralkstterb 12-13-2012 06:57 PM

EML Light & 4 Codes
 
Ive had this intermittent problem for about a month. EML light randomly comes on with check engine light and leaves my car in an undrivable state. Extreme power surging. If I were to push the pedal to the floor it goes from full throttle to no throttle and jerks the car back snd forth until i pull over and turn it off for 10+ seconds. Sometimes it wont come back for hours or days other times it returns immediately. It seems to occur most when my foot has just left the gas pedal like about to make a turn or stop then i notice it again when i hit the gas again to accelerate. Ive searched around about EML problems and alot of people mention something about 'limp mode'. Is this limp mode im experiencing? Limp mode, from what I've read, limits the car to a certain rpm or mph. I have experienced no such limits while experiencing this problem. However, it is very difficult to gain and maintain speed making it pretty dangerous. The car runs completely fine until the EML light comes on. The codes that immediately appear (scanned seconds after an incident) when the EML comes on are as follows...

P0601- internal control module
memory check sum error
P0120- throttle/pedal position
sensor A circuit
P0170- fuel trim (bank 1)
P0173- fuel trim (bank 2)

If anyone could just throw some ideas out there from past experience to just throw me in the right direction I'd greatly appreciate it. Thanks in advance guys.

Weralkstterb 12-15-2012 05:55 PM

Nobody?

floydlloyd85 12-15-2012 06:05 PM

I had a similar problem and i had to replace my crankshaft sensor. It does it now on a slight occasion but this time its coming up as somthing wrong with my cat and the mechanic says it must be the lambda sensor no. If any fault at all occurs the car automatically goes into limp home mode. LHM. Dont know what the control module is but the pedal sensor would almost definatly cause your car to go into LHM if it were faulty.

Dionne11 12-16-2012 02:34 PM

Yeah I got C3101 and C3400 I have no clue what these are its hard to find an answer.

raptorman5174 12-17-2012 12:00 PM

I have these four codes on my car now with a check engine light and an EML. Car currently wont run

p1580
p0120
p0340
p0601

All these codes are pointing to the throttle position sensor and the throttle body with the p0340 pointing at my intake CPS. Looks like in my case I have to replace the entire throttle body but you may want to look here first.

Julioalberto236 12-27-2012 11:13 PM

Had te same problem over here with my 328i 1999 y figured out it was more a electrical problem than a mecanical one since the EML light come and go irregularly, i disconnected the positive pole of the battery and cleaned my throttle body and idle control valve and the EML was gone, but still i dont feel the great old torque i had.. Good luck!

Weralkstterb 01-03-2013 12:29 PM

Thanks for the responses guys! I'll check some of that out.

raptorman5174 01-03-2013 01:22 PM

Quote:

Originally Posted by raptorman5174 (Post 14986667)
I have these four codes on my car now with a check engine light and an EML. Car currently wont run

p1580
p0120
p0340
p0601

All these codes are pointing to the throttle position sensor and the throttle body with the p0340 pointing at my intake CPS. Looks like in my case I have to replace the entire throttle body but you may want to look here first.

UPDATE

After reading a bunch of posts that said to pull your Throttle Body clean it and re-install I decided that purchasing another throttle body would be the way to go. The reason for this is that when i did my CCV a year ago I cleaned it very well with TB spray and my ICV so I know it's not dirty. I found a good used unit on ebay for about $160 and replaced my old one. Before I did my replacement I disconnected my negative battery terminal. After the replacement the car started right up and my CEL and EML lights went out and so far I haven't had any issues return and my car is running very well.

Chalk it up once again to another E46Fanatics Fix for my car. I can't even begin to tell you you guys how much money this web site has saved me in the 6 years i have owned my car. :)


All times are GMT -5. The time now is 07:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use