E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   How can I tell if my new water pump is working properly? (http://forum.e46fanatics.com/showthread.php?t=964661)

seigi009 01-09-2013 12:18 AM

How can I tell if my new water pump is working properly?
 
So, I just replaced my water pump (graf), water pump pulley (uro aluminum), idler pulley and belt. After replacing coolant (BMW 50/50 w/ distilled) and bleeding, I started her up and heard/felt a bump coming from the engine. It got me thinking that maybe something happened to the water pump but I can't tell if it is working. I took it for a 10mile test drive and the temp needle never strayed from the middle and my heat works perfectly.

I was told that if you see a small stream of water running into the expansion tank then your pump is good. Well, my old pump stopped making the stream of water into the expansion tank so I replaced it with the Graf one with a metal impeller but I still don't see a stream either when the car is cold or warm. Do I have some clog somewhere?

I am at 120k and my expansion tank is original (replacing next month) and so are my upper and lower hoses. Thermostat was replaced last year.

I searched high and low for an answer before posting this so any help would be most appreciated. Thank you.

Mango 01-09-2013 01:34 AM

if your car isn't overheating, your pump is working.

if it spins, it's working.

330i ZHP 01-09-2013 06:15 AM

make certain the coolant system and engine are completely bled of air or you will not see that water stream


All times are GMT -5. The time now is 10:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use