E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Driveline, Engine & DME Tuning (http://forum.e46fanatics.com/forumdisplay.php?f=98)
-   -   Misfire codes (http://forum.e46fanatics.com/showthread.php?t=966773)

adrianpl 01-20-2013 11:12 PM

Misfire codes
 
My car is putting out these codes:
p0313 - misfire detected with Low Fuel
p0300 - Random/Multiple Cylinder Misfire Detected
p1345 - Misfire cyl 2 with fuel cutoff
p1347 - Misfire Cylinder 3 With Fuel Cut-off
p1343 - Misfire Cylinder1 With FuelCut-off
p0171 - system too lean (bank 1)
p0174 - system to lean (Bank 2)

I am not sure what I should do first.

What i think is maybe wrong?

Change Spark Plugs? (I have put in new NGK about 10K ago)
New Coil Packs?
or my computer is shot

Whenever my car starts misfiring I turn the car off, and then I turn it back on and it runs good.
It starts misfiring when I am idling usually

Where should I start? Would love to here some feedback from the mechanics on the forum.

adrianpl 01-21-2013 10:31 PM

anyone?

J.Schmidt 01-22-2013 03:12 PM

How full is the tank? It looks like you might have a fuel delivery issue...maybe a bad siphon???

adrianpl 01-22-2013 09:51 PM

Quote:

Originally Posted by J.Schmidt (Post 15085471)
How full is the tank? It looks like you might have a fuel delivery issue...maybe a bad siphon???

It seams to misfire when their is less fuel, I filled up today so i will see what happens

DyeBmw 01-22-2013 09:56 PM

subed, i have the same issue on mine.

adrianpl 01-25-2013 12:01 AM

Quote:

Originally Posted by DyeBmw (Post 15086756)
subed, i have the same issue on mine.

Did u solve it?

bpatel1221 01-26-2013 02:50 PM

Quote:

Originally Posted by adrianpl (Post 15080144)
My car is putting out these codes:
p0313 - misfire detected with Low Fuel
p0300 - Random/Multiple Cylinder Misfire Detected
p1345 - Misfire cyl 2 with fuel cutoff
p1347 - Misfire Cylinder 3 With Fuel Cut-off
p1343 - Misfire Cylinder1 With FuelCut-off
p0171 - system too lean (bank 1)
p0174 - system to lean (Bank 2)

I am not sure what I should do first.

What i think is maybe wrong?

Change Spark Plugs? (I have put in new NGK about 10K ago)
New Coil Packs?
or my computer is shot

Whenever my car starts misfiring I turn the car off, and then I turn it back on and it runs good.
It starts misfiring when I am idling usually

Where should I start? Would love to here some feedback from the mechanics on the forum.

I am having the same issue, i looked around the forums and found something, but what kind of air filter are you using k&n? that could be the reason that its messing up your MAF, may want to try cleaning the MAF or either your MAF is going bad. Try unplugging the MAF and starting the car see how it runs and drive like a block and check.

adrianpl 01-27-2013 12:07 AM

Quote:

Originally Posted by bpatel1221 (Post 15098734)
I am having the same issue, i looked around the forums and found something, but what kind of air filter are you using k&n? that could be the reason that its messing up your MAF, may want to try cleaning the MAF or either your MAF is going bad. Try unplugging the MAF and starting the car see how it runs and drive like a block and check.

nope, it seams like my disa is bad and my Oil separator needs to be changed along with the hoses. Will see what happens after that

adrianpl 02-08-2013 06:26 PM

Disa valve was bad. Problem Solved


All times are GMT -5. The time now is 09:21 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use