E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   E46 Xi Forum (http://forum.e46fanatics.com/forumdisplay.php?f=104)
-   -   Auto Trans doesnt engage (http://forum.e46fanatics.com/showthread.php?t=968541)

RidwanKazi 01-30-2013 04:12 PM

Auto Trans doesnt engage
 
I have been having issues with my 2004 330xi not getting into gear when i shift to Drive. I have an automatic transmission and just baught the car a month ago. This issue has happened two times in the same manner. I park my car in the garage and in the morning (usually very cold due to me living in the Midwest) I turn the car on, warm it for a few seconds, shift it to Drive, and go but i ieither dotn move and my engine revs up or i go really slow (also my speedometer does not move at all). The problem goes away after a little while or if shift to the steptronic option and gear down or up. Anyone have any input?

SamDoe1 01-30-2013 04:48 PM

Change the transmission fluid and filter. It's cold, most auto transmissions act sluggish in the cold.

redbull 325is 02-02-2013 08:32 PM

Check trans fluid level

shadow 2 02-03-2013 03:38 PM

Would not expect your speedometer to move if your car is not. I have same issue. Too cold to check level and no jack stands to get under the car. Will try to find out in the next few weeks if more work is needed.

wedge39 02-05-2013 11:01 PM

If it only happens when you start the car and try to go for the first time, it's a known e46 issue. I had it on my 2003 325xi AT. There is a bulletin (not a recall) out there for it. Dealership reprogrammed computer for a little over $150 and issue went away. It's likely always been like that, and as far as I know it won't cause any problems to leave it that way, you just have to rev it twice sometimes.

shadow 2 02-06-2013 07:01 AM

Like you, I am very hesitant to rev my car when cold in sub freezing weather. Will call dealer and see if the software can be updated.

SamDoe1 02-06-2013 09:46 AM

Quote:

Originally Posted by shadow 2 (Post 15125542)
Would not expect your speedometer to move if your car is not. I have same issue. Too cold to check level and no jack stands to get under the car. Will try to find out in the next few weeks if more work is needed.

I wouldn't wait that long. If fluid level is low, lots of bad things could be happening in there. I recommend taking it to a shop to have it looked at if you can't do it yourself.

redbull 325is 02-06-2013 07:21 PM

i've got a spare trans from my swap :)

shadow 2 02-07-2013 09:32 PM

Curious how the tranny can get low on fluid in a closed system with no leaks. I changed fluid and filter about 50k miles ago. Mine runs fine if temp above 37 or so. My indie thinks it just needs a software upgrade for more internal pressure at start up.


All times are GMT -5. The time now is 05:46 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use