E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   E46 Convertible (http://forum.e46fanatics.com/forumdisplay.php?f=106)
-   -   Another top problem (http://forum.e46fanatics.com/showthread.php?t=968673)

socalragtop 01-31-2013 09:37 AM

Another top problem
 
I just got my car a couple weeks ago. It's a 2002 352ci convertible. Everything was working fine with the top until a few days ago. It went down and wouldn't go back up. My wife reported she heard a clunk sound from the back when it went down. Also this was the first time we had put anything in the trunk. Although we did not push the top compartment up I'm sure it probably was moved a little. When the top went down this time the trunk was empty. I started messing with the compartment by opening and closing it and finally the top closed automatically but it would not latch in the front I had to seal it manually with the Allen key. Since then I have been reading endlessly here and elsewhere about broken wires, sensors, micro switches etc. I have also read the owners manual and the convertible PDF I found here. I want to start checking some of these things but I can't seem to get the top to open manually. I can unlatch the front with the key and I've pushed the button behind the rear seat but the top will not allow me to retract. I have put some pressure on it but don't want to make things worse by pushing too hard. Also I am unable to lift the rear window piece. Any insight on what I should do short of gong to the dealer will be greatly appreciated. Thanks.

taylor192 01-31-2013 11:30 AM

Turn the Allen key more at the front. Not only does it latch at the window, it latches the first joint of the top.

Sent from my Nexus 7 using Bimmer App

socalragtop 01-31-2013 06:33 PM

Thanks it worked. I was able to manually retract the roof but the cover would not lock on its own. I could lock it with the allen key under the back seat. Next I was able to close the top with the switch but it would not lock down to the front. I checked the wires on the drivers side joint and they were ok. I also noticed on the driver's side top well a black plastic wire looking thing with a spring around it. It was broken and just sitting on the hinge. I couldn't see down in the well to see where it came from. After the top closed and wouldn't lock to the front the red light began to flash again and neither switch would do anything. I guess it's off to the dealer ugh.

cityjohn 01-31-2013 08:16 PM

Quote:

Originally Posted by socalragtop (Post 15116978)
I guess it's off to the dealer ugh.

Once they have your OK on the authorization line they will charge whatever they feel like. A friend of mine paid 150 for a dealer to diagnose the top. They gave an estimate of 1,800 and couldn't put it back together correctly -- clearly they were learning on my buddy's car. We fixed the problem for $0.

Try to do it yourself or get some help here, or find an independent shop.

mitfa911 01-31-2013 11:10 PM

I would start by checking under the rear seat bottom cushion. Pull the bottom cushion and there is a plastic box in the middle that controls the top cable mechanism. As this part gets old the plastic gears inside get brittle and break. Let us know what you find.

socalragtop 02-01-2013 12:54 AM

I was in there today. There are three gears and what looks like a little sensor. I was able to lock and unlock the cover using the Allen key. I saw no movement when I pushed the up and down switches. I tried with cover off and on. Another thread suggested the middle gear pops out but it didn't although I could remove it. The gears appear to be made of metal. I was able to push the silver button but it didnt seem to do anything. I also looked for any other broken wires within the top and found none. I did see something broken. A black plastic rod with a spring wound around it. It seems to have been connected on one end to the drivers side bracket by a small hook on the end of the spring. I appreciate the help I really like to do all repairs myself. Unfortunately the last convertible I had was a 1967 Chevy that had a pump and two pistons, no sensors etc. Anyway thanks.
One more thing possibly related. I can only open my trunk with the key. I pulled the rubber wire cover and found a previous fix had come apart. I think the wire is brown with a yellow stripe. I soldered in a new piece of wire but still can only open the trunk by key. Someone suggested unlocking the glovebox which I did but no difference.

taylor192 02-01-2013 08:46 AM

If the car thinks the top is not completely own or closed the trunk will not open electronically. This may help you out since it points to an electrical issue with the top. With my top manually closed my trunk works just fine.

Sent from my Nexus 7 using Bimmer App

socalragtop 02-01-2013 09:47 AM

Makes sense but the trunk didnt work even when the top was working. When I went to buy the car the top wouldnt go up when the guy put it down. He said the trunk wasnt fully closed opened it and closed it and the top worked fine until now. I found an indie nearby Im going to see him today. Send along any ideas. Thanks

dknightd 02-01-2013 10:19 AM

The top will not move if the car thinks the trunk is open. The trunk will also not open if the car thinks the trunk is open. Could be your car thinks the trunk is open?

socalragtop 02-01-2013 10:36 AM

Would that be caused by a faulty latch? I did find the broken wire... I also saw another post on here where the guy found a broken wire under the trunk lining... All the other wires seemed ok

dknightd 02-02-2013 09:36 AM

Could be a bad latch. Could be there is another broken wire that you couldn't see (sometimes the wire breaks, but the insulation stays intact - look for places in wire that are not nice and round).
Now that I think about it though, if the car thought the truck was open, there should be a light on the dash, so, it might be something else.

Let us know what you find.

socalragtop 02-02-2013 06:03 PM

2 Attachment(s)
I did more checking and tested all the connections at the cvm plug as per another thread here. All tested good continuity. I did find the casing on the green/white wire was split so I spliced it just for good measure. I adjusted the bowden cables in and out with no result. If I manually put the top down and lock the cowl with the allen key it will go all the way up automatically but it will not lock to the front window frame. After I turn off the car and remove the key I can hear a clicking from the driver's side mechanism. It clicks 2 or 3 times then stops. I wonder if the cowl is trying to lock itself down. This is the same side I saw the broken spring. I took some pics of the broken piece. I could not tell where this piece might attach. Maybe someone could look at their's and find out? Thanks.

cityjohn 02-02-2013 06:11 PM

That looks like the spring that returns the small sliding cover.

http://i46.tinypic.com/ajtaaq.jpg

socalragtop 02-02-2013 07:38 PM

Could that be enough to mess up the top sequencing? Can you see where it connects? Thanks.

taylor192 02-02-2013 08:07 PM

It is the spring that controls the sliding cover. Mine was disconnected for a week and the top still functioned fine, so I doubt that's your problem. There's no sensor on that cover.

The usual problem with not latching at the windshield is a bad electrical connection. Double check everything, otherwise maybe you have a bad motor in the latch mechanism. With the top manually closed will it electronically open?

Sent from my Nexus 7 using Bimmer App

socalragtop 02-02-2013 08:23 PM

The first time I put it down manually it closed with the button but didn't latch. Now neither button does anything. The red light is still flashing.


All times are GMT -5. The time now is 08:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use