E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Driveline, Engine & DME Tuning (http://forum.e46fanatics.com/forumdisplay.php?f=98)
-   -   Dsc light issue. (http://forum.e46fanatics.com/showthread.php?t=971090)

tabor 02-14-2013 11:37 AM

Dsc light issue.
 
Hey guys. I have looked around for this issue but it seems like every post has other issues...my car runs fine, but my dsc light stays on. When the car is started I can toggle dsc on/off just fine. After I hit 45mph or so it come on as if I turned it off and the light will not go off. I tested to see if dsc was really off and it is. Sooo..my dsc is not working and unable to be turned on over 45mph. Any ideas on this?

Sent from my SCH-R530U using Bimmer App

tabor 02-15-2013 06:17 AM

:bump: anyone before I go to stealership?

Sent from my SCH-R530U using Bimmer App

HiHoBrian 02-15-2013 07:20 AM

You would need to borrow or buy a PA Soft 1.4 scanner and check the fault codes. You could have a faulty speed sensor,or mismatched tires,or any number of issues. The best way to diagnose it is with diagnostics. If you or anyone you know does not have the diagnostics,then it sounds like you will have to pay $$$ to get it checked out.

sent from my ATARI sc1224

tabor 02-15-2013 08:04 AM

Crap..... $$$ it is then lol... thank you

Sent from my SCH-R530U using Bimmer App

vitalik-seattle 02-15-2013 02:14 PM

If you in Seattle area I can check it out for free. I have BMW specific software but deff sounds like a faulty speed sensor. Try cleaning it

tabor 02-16-2013 05:45 AM

Thanks for the offer but I live in VA. The south western portion.

Sent from my SCH-R530U using Bimmer App

2KBMW 02-17-2013 01:34 PM

I have the same problem. the DSC light shows up and stays on sometimes (my tires are getting old though; it might be it)

Repincali 02-17-2013 05:27 PM

I have the opposite issue. No matter how long I hold the DSC button, no light comes on. I'm not sure if its working or not.

tabor 02-17-2013 06:27 PM

Im running two diff. Tire sizes right now...245/55 18 in rear, and 245/45 18 in front.(yes i like meaty tires) I put my style 44's back on an issue went away...so I dunno if it's a faulty sensor but thats whats going on with me.

Sent from my SCH-R530U using Bimmer App

2KBMW 02-20-2013 04:36 PM

Quote:

Originally Posted by tabor (Post 15171576)
Im running two diff. Tire sizes right now...245/55 18 in rear, and 245/45 18 in front.(yes i like meaty tires) I put my style 44's back on an issue went away...so I dunno if it's a faulty sensor but thats whats going on with me.

Sent from my SCH-R530U using Bimmer App

I believe this could be it...my tires are old as fvk lol


All times are GMT -5. The time now is 09:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use