E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   E46 Xi Forum (http://forum.e46fanatics.com/forumdisplay.php?f=104)
-   -   Ignition switch problem or Transmission problem? (http://forum.e46fanatics.com/showthread.php?t=971337)

Bombay Badboy 02-16-2013 12:07 AM

Ignition switch problem or Transmission problem?
 
**Intermittent, leaning more towards always doing this** MANUAL transmission

When i put the key in the ignition, turn it 2 clicks ( 1 away from turning over the enigine), SOMETIMES ( mostly when its in reverse, but not always ) , none of my dashlights come on, and when i try to crank it, it jusr runs the starter, as if there is no fuel supply. it doesnt mattter how many times i try it from there, it wont start.

I've found that if its in first gear and does the above symptom, i so far have always been able to get it started again by turning the key all the way back ( sometimes even removing / reinserting ) , and clicked it twice very fast over and over again until the dashlights come on, and at that point i know the car will turn over properly and start.

But sometimes, even after starting it in first gear, if i put it into reverse, it shuts itself off>???

My personal opinion is that some of the contacts on the inside of the ignition switch is either sticking open, or sticking closed, whatever one it isnt supposed to be doing.

I can buy one for 60$, but do i have to have BMW recode it or something????

Any help would be great thank you!


All times are GMT -5. The time now is 12:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use