E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   Suspension & Braking (http://forum.e46fanatics.com/forumdisplay.php?f=97)
-   -   Clunk on front driver's side driving me nuts! (http://forum.e46fanatics.com/showthread.php?t=972405)

protomor 02-21-2013 07:07 PM

Clunk on front driver's side driving me nuts!
 
I have a 2000 323i with 177k on the clock. I recently did the brakes/control arms/cabs (THR cabs) about 6+ months ago. Within the past 2 weeks, the car has developed a clunk.

This clunk does NOT happen over speed bumps and such. I can get a good 3 clunks really fast if I'm turning left from a dead stop, accelerating up hill. Not always with a right turn. On the highway, I hear nothing. In parking lots, I sometimes hear stuff.

It doesn't seem to be brake dependent at all. I noticed the sway bar link on that side was bad so I replaced that. Sway bushings look fine. Still clunks. I'm going NUTS! What IS IT?!

Andy2108 02-22-2013 04:06 AM

Keep looking around. I'm guessing maybe a broken spring... hopefully. It could be something more serious like a completely failed strut tower or sway bar mount. I guess you could take the sway bar end link out and drive around and see if it still clunks :dunno:

peytonracer4 02-22-2013 04:10 AM

In. I have a slight clunk on my drivers side.

Andy2108 02-22-2013 04:14 AM

Check the top of the strut tower where the strut mount bolts to the car. Also check the weld between the pieces of the strut tower. I've seen cracks form the tower to the fender too.

peytonracer4 02-22-2013 04:19 AM

Quote:

Originally Posted by Andy2108 (Post 15186563)
Check the top of the strut tower where the strut mount bolts to the car. Also check the weld between the pieces of the strut tower. I've seen cracks form the tower to the fender too.

The fender is bolted on and is not structural.

Andy2108 02-22-2013 04:28 AM

Thanks captain obvious. Now consider the inner fender part of your engine bay, which the actual fender is bolted to.

My friend's beat-to-**** m3 has cracks there. My other friend's m3 racecar developed some small cracks there over time.

protomor 02-22-2013 05:59 AM

I'll check more around the welds. The top of the shock tower actually looks fine to me. The spring looks fine as well. I'll double check the sway bar where it links to the frame.

I googled around and some guy said his was just some broken plastic clip and something floating around as a result. What could that be?

protomor 03-07-2013 07:31 PM

Long story short, the Treehouse racing CABs died after only 4 months of use. The bushing needs to deflect or else it just kinda eats away at the insides. Went back to stock rubber. Yay waste of money.


All times are GMT -5. The time now is 11:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use