E46Fanatics

E46Fanatics (http://forum.e46fanatics.com/index.php)
-   General E46 Forum (http://forum.e46fanatics.com/forumdisplay.php?f=4)
-   -   Road Speed Signal Implausible? (http://forum.e46fanatics.com/showthread.php?t=999555)

Chriis325i 08-01-2013 05:13 PM

Road Speed Signal Implausible?
 
EDIT: Problem Fixed. The Bluetooth ULF module was the problem.

Used PA Soft 1.4 and I got that error (Road Speed Signal Implausible) under Digital Motor Electronics. It is in Red meaning currently faulty but I can clear it and remove it but it comes back after some time. Can anyone help me out if they have gotten this then fixed it?

More info: My Speedo and MPG do not work. I have no other lights on my dash. No ABS,BRAKE.. And I have replaced my Speed sensors. I have ran the Odometer test and all lights work and needles. Also get P0500 on OBDII Scanner which says Speed Sensor A. I have ran my car with GT1 I believe and it shows all my sensors working and they each throw out the speed when I am driving.
I am all out of solutions and have tried everything. This problem is driving me nuts for the past couple of months and no one can solve my problem. I need to get the car inspected but I have a CEL.

Zell 08-01-2013 05:23 PM

DSC transmits vehicle speed to the cluster. Since you have replaced your speed sensors, then the next place to look would be the DSC module itself. See if it has any specific errors.

Chriis325i 08-01-2013 05:39 PM

Road Speed Signal Implausible?
 
Quote:

Originally Posted by Zell (Post 15613535)
DSC transmits vehicle speed to the cluster. Since you have replaced your speed sensors, then the next place to look would be the DSC module itself. See if it has any specific errors.

How can I check the DSC module for errors?


Sent from BimmerApp mobile app

Zell 08-01-2013 05:44 PM

Same way you checked your DME :) Just select DSC instead.

Chriis325i 08-01-2013 05:45 PM

Road Speed Signal Implausible?
 
Quote:

Originally Posted by Zell (Post 15613594)
Same way you checked your DME :) Just select DSC instead.

Ok, thanx I'll check it when I get a second.


Sent from BimmerApp mobile app

Chriis325i 08-01-2013 06:03 PM

Road Speed Signal Implausible?
 
2 Attachment(s)
Quote:

Originally Posted by Zell (Post 15613594)
Same way you checked your DME :) Just select DSC instead.

This is what everything looks like.. no errors on the ABS.
Attachment 519642Attachment 519643


Sent from BimmerApp mobile app

Zell 08-01-2013 06:13 PM

Hmmmmm.............well this is pretty odd. I'm starting to think it's going to be something hardware-related that the software itself will not be able to exactly detect. We know it's gotta be somewhere in the following:

- Wheel Speed Sensors
- Wiring from wheel speed sensors to DSC module
- DSC module itself
- DSC module to DME
- DME to instrument cluster
- The instrument cluster itself

We can rule out the wheel speed sensors and wiring to the DSC module because you could see the specific wheel speeds measured.

We know the DSC module is supposed to be working because it is able to receive that information and display it to your computer, which must be passed through the DME because it is done through OBD2.

But the DME is saying it's not getting the signal.

I wonder if it has to do with the DME.

2003silver330i 08-01-2013 06:15 PM

Quote:

Originally Posted by Chriis325i (Post 15613507)
More info: My Speedo and MPG do not work..

That is usually the classic symptoms of a faulty ABS module; however, your scanner says differently. :hmm:

Chriis325i 08-01-2013 06:26 PM

Road Speed Signal Implausible?
 
Quote:

Originally Posted by Zell (Post 15613676)
Hmmmmm.............well this is pretty odd. I'm starting to think it's going to be something hardware-related that the software itself will not be able to exactly detect. We know it's gotta be somewhere in the following:

- Wheel Speed Sensors
- Wiring from wheel speed sensors to DSC module
- DSC module itself
- DSC module to DME
- DME to instrument cluster
- The instrument cluster itself

We can rule out the wheel speed sensors and wiring to the DSC module because you could see the specific wheel speeds measured.

We know the DSC module is supposed to be working because it is able to receive that information and display it to your computer, which must be passed through the DME because it is done through OBD2.

But the DME is saying it's not getting the signal.

I wonder if it has to do with the DME.

Yea, this is a nightmare because I've searched and no one has had the same problem. My last option would be a BMW dealer. :'(


Sent from BimmerApp mobile app

Chriis325i 08-01-2013 06:27 PM

Road Speed Signal Implausible?
 
Quote:

Originally Posted by 2003silver330i (Post 15613682)
That is usually the classic symptoms of a faulty ABS module; however, your scanner says differently. :hmm:

I've considered sending my ABS to modulemasters but I dont wanna just throw that money away and then it does not even fix my problem.


Sent from BimmerApp mobile app

TerraPhantm 08-01-2013 07:15 PM

Any chance you've done a bluetooth retrofit recently?

Chriis325i 08-01-2013 07:20 PM

Road Speed Signal Implausible?
 
Quote:

Originally Posted by TerraPhantm (Post 15613823)
Any chance you've done a bluetooth retrofit recently?

Yes, I changed the module in the trunk and also put the piece that goes in the center console.
Please tell me thats the problem and you know how to fix it lol


Sent from BimmerApp mobile app

Slapsys 08-01-2013 09:43 PM

Quote:

Originally Posted by TerraPhantm (Post 15613823)
Any chance you've done a bluetooth retrofit recently?

Man,your car in the sig block has to be one of the nicest on this forum. Well done.:thumbsup:

Zell 08-01-2013 11:16 PM

Quote:

Originally Posted by TerraPhantm (Post 15613823)
Any chance you've done a bluetooth retrofit recently?

Quote:

Originally Posted by Chriis325i (Post 15613832)
Yes, I changed the module in the trunk and also put the piece that goes in the center console.

Bam.

TerraPhantm. Resident BMW electronics expert. :bow:

daki_bmw 08-02-2013 10:17 AM

Quote:

Originally Posted by Zell (Post 15614304)
Bam.

TerraPhantm. Resident BMW electronics expert. :bow:

x100000000

That guy. Genius. :bow:

Chriis325i 08-02-2013 11:19 AM

Road Speed Signal Implausible?
 
Quote:

Originally Posted by TerraPhantm (Post 15613823)
Any chance you've done a bluetooth retrofit recently?

I think I love you. Lol The problem is solved I woke up this morning disconnected the module, went for a drive and saw the needle going up and I got so happy. After months of tearing this car apart. Who would of thought that stupid bluetooth module would have cause me so much misery. Thanks so much.


Sent from BimmerApp mobile app

Chriis325i 08-02-2013 11:21 AM

Road Speed Signal Implausible?
 
[QUOTE=Zell;15614304]Bam.

Thanks for the help also and to everyone else that contributed.


Sent from BimmerApp mobile app

TerraPhantm 08-02-2013 02:51 PM

If you remove pins 7 & 8 from the 54-pin connector, you can get the bluetooth module working without interfering with your speedometer. More info here: http://bavariansoundwerks.com/produc...tall_-_E46.pdf (page 8)

Chriis325i 08-02-2013 03:45 PM

Road Speed Signal Implausible?
 
Quote:

Originally Posted by TerraPhantm (Post 15615600)
If you remove pins 7 & 8 from the 54-pin connector, you can get the bluetooth module working without interfering with your speedometer. More info here: http://bavariansoundwerks.com/produc...tall_-_E46.pdf (page 8)

Ok, thanks.


Sent from BimmerApp mobile app


All times are GMT -5. The time now is 06:47 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use