E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.


Go Back   E46Fanatics > Search Forums

You searched for the keyword(s):
Your search results are listed below. If you did not find the answer you were looking for, please try searching again. Make sure that you are searching the entire site and not a specific forum. If you cannot find the answer to your question, create a new discussion topic in the appropriate BMW related or Off-Topic section.

Showing results 1 to 8 of 8
Search took 0.53 seconds.
Search: Keyword(s): ; Posts Made By: turko
Forum: The Tire Rack's Tire & Wheel Forum 11-07-2007, 02:29 AM
Replies: 5
Views: 863
Posted By turko
Yeah it was a defected eye from the box, no...

Yeah it was a defected eye from the box, no matter how many times i tried as soon as i pop the headlight back in the loop pops out :-( i have to send it back to the company, just been lazy lately....
Forum: The Tire Rack's Tire & Wheel Forum 11-07-2007, 01:30 AM
Replies: 5
Views: 863
Posted By turko
Phoenix Yellow Color Matching Wheels

Hi Guys,

I was just wondering if theres any photoshop pros with a little extra time on their hands. I want to paint my wheels, but i can't decide whether to paint the lip or the everything...
Forum: Bavarian Soundwerks' Mobile Electronics Forum 10-25-2007, 03:58 PM
Replies: 29
Views: 1,492
Posted By turko
Guys i really apreciate everyones help!!! I...

Guys i really apreciate everyones help!!!

I Already have an extra battery by kinetic, dont know which series but its blue.

Basically i just feel i have these 2 monster subs but im lettin them...
Forum: Bavarian Soundwerks' Mobile Electronics Forum 10-24-2007, 11:08 AM
Replies: 29
Views: 1,492
Posted By turko
No offense taken at all bigjae1976, i really...

No offense taken at all bigjae1976, i really appreciate your time n help. As i said im a newbie at this and it seems i trusted the wrong guys when it came to my system. Basically i got a real good...
Forum: Bavarian Soundwerks' Mobile Electronics Forum 10-24-2007, 10:21 AM
Replies: 29
Views: 1,492
Posted By turko
Yeah i kinda figured the amps wont be enough...

Yeah i kinda figured the amps wont be enough either, but they seemed to be one of the best. But their only 1000W when each of these subs are meant to handle 5000. The box is sealed, i might just take...
Forum: Bavarian Soundwerks' Mobile Electronics Forum 10-23-2007, 06:35 PM
Replies: 29
Views: 1,492
Posted By turko
POWERFUL SYSTEM, which head unit?? Help

Ok, so i had a system done some time ago consisting of the following..

2 SOLO X 10" Woofer
JL ZR650 all around intereior
2 JL 1000/1 Amps
1 JL 450/4 amp

I had everything wired to my factory...
Forum: Polls & Surveys - Please Participate! 04-03-2007, 12:11 PM
Replies: 57
Views: 15,318
Posted By turko
21 bought e46 m3, 19 had e36 325i, sell...

21 bought e46 m3, 19 had e36 325i, sell electronics on ebay lol. Daddy smacks off the puppy eyes. theres actually more owners above the age of 30 (stockbrokers, etc) they just dont come on these...
Forum: ///M3 Forum 04-03-2007, 11:54 AM
Replies: 35
Views: 1,579
Posted By turko
Hi, if you have aftermarket wheels, the reason is...

Hi, if you have aftermarket wheels, the reason is because you did not order the valve sensors with those wheels, or one of the senors on the original wheels went bad so there is no signal going to...
Showing results 1 to 8 of 8


 

All times are GMT -5. The time now is 09:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use