View Single Post
Old 11-17-2009, 02:48 PM   #10
bombguy
Registered User
 
bombguy's Avatar
 
Join Date: May 2006
Location: Redondo Beach, CA
Posts: 2,153
My Ride: 2004 M3
Quote:
Originally Posted by CHFBrian View Post
The DSP button does still work, and it seems to work exactly as before - making the sound field mroe "concentrated" for lac of a better word.

The Alpine unit has built-in bass and trebls controls that work well. It also has the ability to set bass and trebl control frequencies, a feature I havent played much with yet. So far the sound is very good. Radio is as good or better than before, and the ipod sound fantastic.

That said, I could never get a huge amount of clear bass before, and i still can't. Turn it up a ways and you can hear it start to fart. A new sub or a whole new amp/speaker setup will really be needed for that. But for me, this sounds great.

Awesome. I've been stuck in the middle as far as sticking with a stock unit and adding iPod through the aux.. Since your review, and for a few $$ more, it only makes sense to get better sound and more functionality. I will be doing the same route later....piece by piece replacing the stock speakers and installing amps and subs but this sounds like a good start!

Did you have to pay extra for the iPod cable or did it come with it, also where did you route your cable? Thanks!
__________________
2004 JB
KWv2, Spacers 15/F-10/R, MVR Rep, Alpine IDA-X305 w/ KCE-BT400 Bluetooth,
Agency Power Exhaust, Khoalty AE's
bombguy is offline   Reply With Quote