View Single Post
Old 05-29-2011, 11:04 PM   #1
xiocer
Registered User
 
Join Date: May 2011
Location: montreal
Posts: 10
My Ride: 328i
Trany Problem E46 328i

Well hi guy's i was looking for the entire forum for something simililar and did not find anything.

Well my problem is the trany, everything is ok at the begining i start the car put the D gear and the car goes perfect at cold, When the car is hot it shift but i little hard but no big deal. The car goes from first to second to third to four and no problem when it shift to fift on the high way at 100kmh boom limp mode.

But if i keep the car all the time on the 4S i can go 180kmh and there is no problem at all at any time. The car drives super in 4S or 3S even 2S but not on D.

I did scan the car with an PA Soft computer and it gave me Torque low Pressure, Solenoid low pressure.

My big question is what is going on, what do i need to change??

Because when i press the gas the tranny does not lag at all, in first it even spins the wheels, the 2,3,4 gear goes superb and quite fast.

I smell like the trany oil in the car not all the time.

I had another car with torque problem and you feel it right away.

The car had never been flushed from the tranny at my knowledge, can it be the solenoid? the Oil?

If you guys can help me i will really apreciate.

Last edited by xiocer; 05-29-2011 at 11:05 PM. Reason: missed info
xiocer is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.