View Single Post
Old 10-21-2011, 11:40 AM   #1
Nervous
Registered User
 
Join Date: Dec 2010
Location: MD, USA
Posts: 1,486
My Ride: 01 330CI 6MT ZSP EU3
A/C diagnostics, lots of info w/pics

Hey,

Maybe you can help me to diagnose what's wrong with my A/C. Symptoms: A/C doesn't engage immediately when ambient temp is about 15-20 C (worked fine during the summer). However, if I drive for about 30 min it finally start to blow cold air (compressor engaged). I decided to check pressure as the first step. I have the following manifold (it is MasterCool 99134-A digital manifold):


My setup:


The reading was the following:
Ambient temp (according to the value on a dash board): 15C (59F), a bit cold for this kind of work, isn't it?
Low side pressure: 30 psi
High side pressure: 230 psi

If I understand correctly, both pressures are too high, isn't it? Especially high side. According to the chart from the manifold's manual, at 65F it should be 25-35 psi for low and 135-155 psi for high. My high is 230 psi!

Note, this was measured when A/C was turned on full blast (min temp, max blower). Our e46s have variable displacement compressors, which are able to change pressure in runtime. Once I increased the temp settings and decreased the blower my readings have significantly changed: 30 psi / 178 psi.

Now they look "more normal", aren't they?

Last edited by Nervous; 10-27-2011 at 12:04 AM.
Nervous is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.