View Single Post
Old 01-04-2012, 02:20 PM   #1
traxem
Registered User
 
Join Date: Nov 2011
Location: Seattle
Posts: 6
My Ride: 325i
Send a message via AIM to traxem
Angry 2004 E46 - TCU buzzing and whining problem

I recently swapped my TCU (with assist) out for a new one (with assist and bluetooth). Picked it up brand new at the dealer. Right out of the box, it paired up and voice command was functional. However, when the system is activated (either when phone is in-use or voice command is activated), there is a constant background "hum" when the key is on position II (DRL on) and a high-pitch whine when the engine is on. It sounds like a bad ground. The system is flawless when the key is on the I position (radio power only).

I asked the dealer to diagnose the problem. After an hour of labor ($$), the tech told me that he couldn't figure it out and recommend programming since it was never programmed. After another 1.5 hours (more $$$) for programming, the problem is still there!

Refusing to declare the unit defective, the tech is telling me that there was an install kit that came with a harness. The dealer suspects that the missing harness (that BMW NA doesn't make anymore) might cure the problem. They won't install another TCU to test it because they can't resell it after it's been installed. They told me that I can buy another TCU and if that fixes the problem, then they'll take the old TCU back (as defective). But if the new TCU also has the same problem then I'm stuck with two TCUs.

The sound is similar to a bad ground. I saw similar problems in other threads but no solution.

Does anyone have any suggestion other than to buy another TCU to test it?
traxem is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.