View Single Post
Old 01-22-2012, 10:32 AM   #66
navman01
Registered User
 
Join Date: Feb 2011
Location: Victoria Australia
Posts: 14
My Ride: 2004 318i E46
Quote:
Originally Posted by mcondruz View Post
Hello

I have an issue with my Dynavin sd card. the card is not loading. I am sure it is correctly formatted and the device hardware is functioning (since the ROOM replacement is working when I update it with the latest Dynavin firmware).
However, after the system is loading I can see no card. I tried more cards, including the one which have the firmware. Nothing.
For more info I tried with those cards:
- one 2Gb card Fat 16 formatted
- one 2Gb card Fat 32 formatted
- one 8Gb card Fat 32 Formated

Partitions are Primary and Active on all of them. Still nothing.

It is also important to say that yesterday was working, I moved the IGo from the original card to the bigger one (8Gb), intalled it, tested it, etc..
Today, nothing. My Igo is saying he need the sd crd. I reloaded the firmware (wipe all the data with this ocasion and I loaded it from sd card which for purpose was working). When system is booting, still nothing.
Any idea?

The softwares on the market like reload the sd card specific softwares are also ineficient . Please help. I am almost sure it is a Android system issue.
+1

~ SD ~
Similar issue here, the stock SD card (2gb) was working, I downloaded MapDroyd Maps to the device and then even updated to 2.2 with it. Cant confirm that it happened after the update.
I go to download the Speech Synthesiser for Google Nav but kept getting a need more than (6 by memory)mb of storage.
Ive been able to get the SD to work for a few seconds when mounting, then formatting, then not getting a response from MayDroyd saying that I dont have an SD card which was good but it appeared to fail on me again. It doesnt appear to last long.

Also had a corrupt sd card notification, formatted but it still buggy. Anyone else having similar issues? Im about to try an old 1gb SD card and see how that goes.

SolutionUpdate=== Played around with the sd card and eventually got it formatted on the android d99 unit and its working now with all SD cards, just have to be careful when mounting, unmounting. For me I will only mount while in the android side, in the sd settings menu where I can see the mount sd button,
1. Insert sd card
2. Tap Mount sd card
For dismount I again only do so when in the sd card settings,
1.Tap unmount and wait a few seconds after confirmation of dismount.

Do not put the left side sd in the right side sd of the unit, the card gets a "requires format/damaged sd card" once its back in the left side (nav)


SD Card formatting
Quote:
Originally Posted by jneumann View Post
Ok, quick update:
I got bored, so I started hacking at the Android side. It appears to be very similar to the TI OMAP35xx hardware used in the BeagleBoard. Android is not designed to run natively on this hardware, so it is emulated in qemu with something called Goldfish.
I managed to figure out how to extract the ubi.img file, edit the contents, and rebuild it to something flashable. (currently running my own "custom rom" right now)
I also have root. Working on the force close issue right now. It reared its ugly head ONE REBOOT after first boot, after installing Titanium Backup (root). I'm assuming it has to do with having so little memory to work with on these devices. (128mb I think?)
I plan to release a slightly tweaked version of Dynavin's last release, with out 3g (I don't use it, and I'm assuming most of us here don't, so it's a pointless kernel module to load) and with a bunch of the preloaded apps either removed or updated. It will also be rooted, or at very least root-ready.

Little start to the information -
How to format ANY SD card so the Android side will boot it and load the firmware off it

Must be FAT (otherwise known as FAT16), and set as active. This means no more than 4gb. (you can use larger, but you will have to reformat after to get the rest of your space back)
I used EaseUS Partition Manager to do this. It's free, and is less pissy than Window's disk management, and easier to use than DISKPART.
All you have to do is delete the partition on your SD card (helps to have a dedicated reader here, most phones probably won't work for this), create a new primary FAT(16) partition, and set it to active. Apply changes, wait for it to sync with the OS. Then just load the update files like normal.

From what I've heard, and what I have experienced over the last several hours, it is VERY hard to brick the Android side. (granted, all I've messed with is ubi.img)

Jeff just sent me the magical app that does all this, and I would recommend just doing it the way I just explained if you know anything about partitioning, or are willing to risk messing up an SD card. It is pretty hard to really mess one up though. 98% of the time you can reformat the SD card back to what it should be using a lower level partition manager like DISKPART or EaseUS. PM me if you really b0rk one, and I'll try to help.
Anyways, the reason I suggest using EaseUS is because I'm not a huge fan of using programs that I can't understand due to it all being in Chinese.

Regarding further development:
I would love to get AOSP Gingerbread working on this thing, but it may be out of my knowledge area, and given I only have time on weekends to work on this, I may never get around to it, much less release a working 2.3 ROM for the Dynavin. If anyone here knows anything about Android development and would like to help, PM me. I'll need it.
Other things I'd like to try to do is get some sort of Bluetooth adapter working so we can use Torque. This may also never happen though, since Torque is a HUGE CPU and RAM hog. My HTC Desire died a little while back, so now I have a low end Samsung Acclaim and Torque runs like sh1t on it. The Dynavin is even lower end hardware than the Acclaim, so Torque may be an impossibility for us.


Big Bold Disclaimer: If you don't easily, fully understand what I am talking about in this post, you are best off not doing or following any of it. I am not responsible for anything bad happening, such as bricked SD cards, Dynavins, things starting on fire or going bump in the night. You have been warned.

In other issues

~ USB ~
My 4GB USB seems to have been converted to FAT (64KB allocation size) and Ive been having everything from freezes/hangs to inability to error codes regarding not having sufficent privileges on my Windows 7 (Im an admin... which makes things interesting). Also it keeps saying it is write protected... I managed to put a few files on while plugged into the pc then all of a sudden it was write protected.
Trying to format to FAT 32 defaults and its just not letting me, or at least it does but it just takes way to long to do and appears to freeze


~ Voice Input ~
-Has anyone had an issues or has been able to get their microphone to function on the android side of the d99. (Voice input a destination, Shazam a song, or make a memo etc)

~ Bluetooth ~
Has anyone else gone into their android side setting tried to turn bluetooth on, only to get no change aka switched off still aka Turn bluetooth on message still displayed.
Also any app that requires bluetooth and it asks you to turn it on, when you go to do so, the unit freezes on me.

Has anyone figured out how to trick bluetooth streamed music(radio side) into working on android side. Jeff has mentioned a push NAV and then mode to get it to work
Quote:
Originally Posted by jeffb325@DynavinSolutions View Post
For the streaming/nav conflict thing, its not perfect but there is a workaround, press the mode/source button first, then select nav. Somehow it tricks/confuses the controller and the audio continues to stream from bluetooth even though the video switches to the nav/android side. But sending any number of commands will cause it to switch off, so in that case you are best off just plugging into the ipod plug.
but this hasnt worked for me. However I randomly got it to work on android side once, and attempted to replicate what I think i did but no luck on doing it again

~ Erase and go to Factory default ~
Ive already tried doing this and have not been able to actually go back to factory default for android, my apps are still there.
"Solution" (Getting around it by reinstalling Android firmware)

~ Android side media ~
Quote:
Originally Posted by mdh View Post
Anyone know of a way to get usb (music and video files) to work on the android side? I can get a hub to work with the supplied wifi radio but the media files will not show up in android.

I can plug in a thumb drive or even a hd to the android usb via a hub and i get a message "preparing udisk" but that is it. I can not locate the files anywhere...
If I pull the drive it will give me one of those messages to unmount udisk berfore removing.

Any ideas?
+1 again on this.
I'm assuming that if you own an android mobile you can somehow connect to and stream your media across it?? 0.o? Anyone?

~SD CARD SIZE~
Anyone have any idea what the max size possible for the d99 unit is?
Quote:
Originally Posted by R75 View Post
I have a 32GB Class 10 Samsung SD card running successfully. I am told it should go to 64GB but that is beyond my needs, so havent tried that.
I'm currently using a Kingston 16gb SD card no problems.

~Apps requiring an internet or data connection fail to work / .COM .NET ERRORS?~
Quote:
Originally Posted by navman01 View Post

AngryBirds, GarminMechanic, DigitalSpeedometer Free, MapDroyd (edit: this had no issue, completely offline app), Market at one stage was no going to net by memory, Navigation etc

Started have force closes, after using a friends phone, HTC Android to tether his 3g data connection to my unit.
All the force closes are "com" 99% of the time or "net"

to solve this issue with all internet or data required apps crashing, I reset data on pretty much all google apps, i think i was successful on settings storage reset.
Everythings working no problems now 2hrs in
SOLUTION:Update 9/feb/12: Clearing your settings storage cache/data will fix the issue, I have now used a mobile twice and each time after use attempting to connect to my wifi at home failed so cleared the cache/data fixed the problem, only side effect is that you lose the SHORTCUTS on your menu android side, but are still all there in the alphabetical listing.


~ FREE OFFLINE TURN BY TURN VOICE NAVIGATION ~
I mentioned MapDroyd before which is a great offline worldwide map, but I need that voice nav.
There is NavFree however you still need a data connection to search for addresses.
Does anyone know anything thats available? Ive been looking around but nothing truly offline and free Might buy Sygic, Im glad they offer a trial because Id hate to buy an app only to find it doesnt bloody work on my android d99.

However I have been able to get Google Maps Navigation to work "offline".
Parked in my garage I got the directions to my destination, and drove away. It worked fine, however I did not have the voice synth installed (my sd issue leading to download issues) so cant confirm if that would work.
Only downside is that when you go to close the app mid drive, it will cancel navigation and wont remember the route... bummer.

Lots of things to discuss, hoping to provide as much as I can as I learn about this unit and android.

Last edited by navman01; 02-09-2012 at 12:48 AM. Reason: More issues with the d99 unit... What the hell dynavin, terrible
navman01 is offline   Reply With Quote