View Single Post
Old 05-03-2012, 12:04 AM   #289
323guy
Registered User
 
Join Date: May 2007
Location: USA
Posts: 67
My Ride: 323, X3
Quote:
Originally Posted by 323guy View Post
I have a 2000 ( manufacture date of 09/99) E46 323iT. I just hit 115,000 miles. I got my car back from the dealer last Monday. I had taken it in for the no reverse problem and the dealer "suggested" replacing the solenoid as a "possible" fix. The problem I had been experiencing was sometimes reverse acts like a second neutral. But after I drive for like 10 minutes or so in Drive, reverse works again. What the heck?

Anyway, This happened again (*&^%$#@) last night even though it went into reverse several times just fine earlier yesterday.

Just looked at the Dealer receipt. They replaced three Solenoid valve on/o all with part # 24337504753 - and filter & fluid - DEALER DID replace the 24327532013 Pressure regulator,convert.lockup clutch.

Problem remains... apparently this same problem would exist with sticking values as well - the dealer tells me. Sweet!

Still goes into reverse when warm every time.
well its been going into reverse when cold now. It did give me problems twice last week after driving 15 minutes... this never happened before. I am going to replace the fluid & fluid myself once the weather improves here. I need to search this site cause I remember coming across a DIY posting where the guy flushed the entire system by pulling a line going to the cooler I think.
323guy is offline   Reply With Quote