View Single Post
Old 06-09-2012, 05:21 PM   #1
FightingSioux
Registered User
 
Join Date: Jun 2012
Location: GA, USA
Posts: 6
My Ride: 2005 330Ci
Exclamation 05 330ci headlight out

My recently purchased 05 330ci has stock HID xenon with autolevel and the lights turn when I turn (whatever that is called). Driver side low and high went out with error light on the dash and fog lights came on automatically. Took to dealer and they swapped xenon lamp control modules (ballast?) between driver and passenger side. Now passenger side was out but driver side was working, confirming xenon Control module (ballast) problem. They wanted $1,000 for new module and labor. Found posts on here to DIY, ordered used part and have done the following:

Driver side was working and passenger side was out when I left the dealer and started the below process.

Put new Control part on passenger side. It works fine and error on dash is gone but immediately the driver side is now out and has the error on dash. I didn't touch the driver side at all and it was working up to the point I put the part on the passenger side.

Swapped current Modules between driver and passenger side but driver side still out and passenger works. Both Modules work on passenger, neither on driver.

Swapped igniters and both work on passenger, neither on driver.

Installed new bulbs, passenger works, driver still out.

Every component seems to work on passenger side, but nothing on driver side.

Checked fuse 9 and 32, both seem fine.

Is there an error code or setting that needs to be reset in the electronics? If so why did the passenger side work after I replaced the original bad Module?

Sorry for the long post, but wanted to give as much info as possible.

Thanks for your help.

Last edited by FightingSioux; 06-09-2012 at 09:33 PM. Reason: Changed part terminology
FightingSioux is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.