View Single Post
Old 07-02-2012, 11:00 AM   #41
mekaneck
Registered User
 
Join Date: Apr 2007
Location: Illinois
Posts: 154
My Ride: 2003 325xi
I just repaired mine with the help of this thread, it was pretty simple. My left brake light wasn't working (but only when my headlights or parking lights were off) and both left and right blinkers weren't working. I've got everything working now, and took me about an hour. Here's a simple DIY:

1. Remove the black box from your tail lights. It's connected by two connectors; one to the tail lights and one to the resistor.


2. Get the circuit board out of the black box. It is basically a container that they set the circuit board into and then fill up with epoxy, so it isn't easily removable. I had to use a hammer and wood chisel to basically destroy mine to get inside. It may not look like it, but I tried to do as little damage as possible so that I could maybe tape the box back together when I was done.


3. Take a soldering iron and heat up and re-solder the pins. I re-soldered any that didn't look perfect; there were a couple that had a dark ring around the connection. I did NOT solder any together, I just fixed the connections that were already there. I think I re-soldered about three connections on each tail light. The small pins looked fine, I just focused on the large solder joints. I didn't use any new solder, and I didn't suck any old stuff up with de-soldering braid. I just heated and re-melted what was there already.


4. Plug the circuit board back in and test everything. Once you get it all working, wrap up the board in electrical tape. I put some of the remains of the black plastic box back on for protection, and then taped it all up. Who knows how long this fix will last, but it's working perfectly right now. Fortunately it will be easy to re-solder if I have to do it again.
__________________

2003 325xi Black
mekaneck is offline   Reply With Quote