View Single Post
Old 08-02-2012, 01:36 PM   #30
waterdale
Registered User
 
Join Date: May 2012
Location: Avon Ny
Posts: 7
My Ride: 2001 330Ci Conv
I had the same problem with my 01 330 Cic. The "dummy" ligts for taillight problem would go on and off (mostly on) until one day it to continuously on. I checked the wiring to taillamps to see if my car was affected by the insufficient ground plug design that has been so well documented elsewhere on this site. I found no evidence of a problem, but I proceeded to make the recommended bulb plane gronding repair anyway. No dice. Finally, (what a dummy) I realized my license plate lights had stopped working. I found the bulbs were both blown, so I replaced them, but they still didn't work. Then I found there was no voltage at the lamp socket. I began to wiggle the bundle of wires inside the rubber sleeve that run from the right front of trunk lid to the body, and to my surprise, the license plate lights began to flicker on and off. I cut open the rubber sleeve, and I FOUND THE PROBLEM! AT LEAST SIX FO THE WIRES BUNDLED THERIN were very visibly damaged - with a couple nearly cut through. Just a jiggle on one of the wires that fed the license plate lights, and it broke in two. SO, I a soldered in splice in the most damaged, and wrapped the remaining less-damaged (but not cut throgh) wires in electrical tape, and viola, everythings worked. And best of all, no more light-out indicator warning light at the dash.

Last edited by waterdale; 08-02-2012 at 01:49 PM.
waterdale is offline   Reply With Quote