View Single Post
Old 08-28-2012, 05:32 AM   #2810
jonnye
Registered User
 
Join Date: Aug 2012
Location: Somewhere
Posts: 1
My Ride: S3
Dead Dynavin Android?

Hi Guys,

I've had problems with my D99 Android since about a month after the install and have been lurking on all of these forums ever since. Since there is no dealer where I am, I brought my unit from the US (regrettably not from Jeff) and wanted to try everything I could before taking the "defective" (maybe?) unit back to the States and returning it under warranty. So please bear with me as I describe my long saga with my Dynavin and maybe someone here (JEFF!!!) can see if there is something that maybe I have overlooked.

Lets start off with saying that I drive an Audi S3 and that my unit is of the A3 variant but I am assuming the internals are identical to the ones in the the BMW's.

The first problem I had was, during install, with the CANBUS adapter that continually reset the unit (about once every 10 seconds). My installer said that it was a cheap Audi CANBUS controller that he had seen for other head units made for Audi and that it was probably defective but, by cutting the red wire from the CANBUS adapter and connecting it directly to the ACC, the problem was solved and the unit worked (apart from occasional issues with the Driver Information Display not updating and occasionally the steering controls not working which the installer said was all part of the "cheap" CANBUS controller). These issues never arose again, so I don't think it's a problem but wanted to add it for completeness.

The real problems started with the Android side of the Dynavin often coming up with application error messages, hanging and having to exit (internet radio/gps/settings.apk/etc.) I ignored these error and did some factory resets which did not help. I just assumed that the unit was slow/memory restricted and I would just live with occasional resets. However, at some point, the Android side itself started to reboot for no apparent reason. I decided to live with this also. However, about at this point, I found it weird that no matter what I did, I could not get the unit to turn off without removing the key from the ignition (holding the left knob down for 4 seconds, which I think used to turn it off, did nothing, neither did any other key combination I could think of). However, at the time, all I had to do if Android was buggy was turn the ignition off and on at a stop light to get the unit to reset, so I kept going on with life and ignored the annoyances.

A few months later, I left on business for 5 days and had to leave my car parked at the airport. My car is black and has a black interior so it does get hot. When I returned to use my car, the Android side refused to boot (i.e. it shows nothing on the screen, just black). I only refer to parking at the airport because this is the only thing that I can think of that changed between it working and not, however I have a Valentine One/Cheetah/Blinder combo in my car and nothing ever happens to them when left out in the hot car.

Now, this happened about 2 months ago and I have tried pretty much everything that I could find on all of the forums. The first thing that I did was take the original 2GB SD and load the stock firmware onto it from the Dynavin website. Since my unit is not booting, as expected, this did nothing. Next I thought that maybe the wireless dongle at the back is preventing the unit from booting. So I took the unit back to the installer and asked him to remove the dongle and place a USB extension cable to the unit so that I could plug and unplug the wireless dongle before the unit boots up (as M3Evolution recommends). I tried every combination under the sun to get the unit to boot: with the stock firmware SD/without, with the wifi/without even with and without the SD for the "radio side" of the unit and nothing worked.

Now I know that you are supposed to turn the unit off and back on with the ignition in the car, but as I mentioned before, one of the things that stopped working right from the start was the ability to turn off the machine with the left knob. So, I decided to go on a crusade to use the remote to turn on and off the unit. Since I received the remote without a battery (no idea why) and the battery, CR2025, for the unit is very elusive and I couldn't find one in my country (only CR2016/32), I had to order one from China on ebay. After waiting forever for the batter to arrive, I put it into the remote and... nothing. Not volume, not power, not next track... nothing. I took the remote apart to try to see if it was damaged and tested it with a voltmeter to see if there was a PD drop across the LED when I push a button and I think it is working fine. So, it seems that my Dynavin unit is also not responding to the remote control (however I do not know if it ever did because I did not have a batter for the remote when the unit was newly installed).

I had completely given up on the unit and was about to throw in the towel (and order a Zenec head unit locally) when 2 weeks ago I was driving non-stop for about 2 hours and I accidentally hit the Navi button on the unit and, lo and behold, there was my Android screen sitting there (not formatted back to stock or anything which means that the SD with stock firmware had never been restored even if the screen was perpetually black). The Android side was exactly as I had left it with all of my apps installed and my shortcuts on the dash, however some of the settings has been lost. I played around with the unit for a while and it worked perfectly apart from Wifi not working at all. So i decided to disconnect the wifi dongle completely and use the unit entirely "offline", it was better than nothing. For a few weeks, the unit worked sometimes. I mean, sometimes I got in the car and android booted right away, sometimes it took 10 minutes with a black screen and then all of a sudden Android would boot, and sometimes I drove for an hour with a black screen and nothing.

Even though this was piss poor (an offline Android Dynavin that works depending on its mood/the day of the week/the weather) I decided to live with it because the alternative of dismantling the unit, taping up the gaping hole in my dash while I send the unit back to the States and waiting for a replacement, having to release it from customs and paying for the dismantle and the reinstall was much, much worse.

However, alas, even this did not last and my Android side of the Dynavin has committed suicide again and for the last 3 days I am navi-less. Since I am traveling to the states next week for a month, I have decided that if I can't fix the unit before I leave, I will have it dismantled and will bring it with me and hopefully have my dealer replace it with a new one before i leave again and can bring it back with me. That way I will not have to live for a month with a hole in my dash where my Dynavin used to be.

I have a few questions:

1. Is my unit defective?
2. If not, is there any way to turn it off except holding the left knob down for 4 seconds or using the remote (neither of which work).
3. Is there anything else that I can do to try to get this thing to work?
3. Are the A3 D99 Androids less stable/have worse hardware than the BMW ones that seem not to have these problems?

I really, really wanted to love this unit with all of its flaws. It looks great in the dash, the online feature is amazing, and I enjoyed the unit for the first 2 months before the problems started. However, this saga has been really testing, despite being optimistic that I can somehow fix the unit if only I did this or that to get it working. Now, i am quite tech savvy so if there is anything that I can do (short of dismantling my dash) I'm pretty sure I can follow the instructions.

Please, please, please help me. I am on the verge of desperation.

Jonny E
jonnye is offline   Reply With Quote