Thread: Loosing Power?
View Single Post
Old 09-19-2012, 11:55 AM   #1
apmanzojr
Registered User
 
Join Date: Sep 2012
Location: californiA
Posts: 11
My Ride: 323I
Loosing Power?

Hi Guys

I was driving my car today 1999 323i E46 auto and I have noticed that when I am stepping on the accelator that especially when it passed the second gear that I felt like I have no torque power it drives okay and the engine seems like there is nothing work however but it felt like something is not right.. I noticed also that when I am accelerating the MPG meter is always high and when I am slowing down and even I letting my foot off the gas I noticed that the MPG meter is still going up especially my tachometer is going to normal RPM and the MPG even it goes up again up to 20 and goes back down to zero.

Hi Guys
I was driving my car today 1999 323i E46 auto and I have noticed that when I am stepping on the accelator that especially when it passed the second gear that I felt like I have no torque power it drives okay and the engine seems like there is nothing work however but it felt like something is not right.. I noticed also that when I am accelerating the MPG meter is always high and when I am slowing down and even I letting my foot off the gas I noticed that the MPG meter is still going up especially my tachometer is going to normal RPM and the MPG even it goes up again up to 20 and goes back down to zero.

Sorry if it is confusing it's my first time that I have experience this with this car and it's hard to explain. I did changed the spark plugs last week and use bosch I have learned that it should be NGK I am thinking of changing it back to NGK this week. I wonder if this is the cause of it any ideas what is ist?


but there were no check engine light in my car


Thanks
apmanzojr is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.