View Single Post
Old 10-03-2012, 08:26 AM   #9
LeMansteve
Registered User
 
Join Date: Nov 2008
Location: USA - GA
Posts: 1,650
My Ride: '04 330i 6mt ZSP ZPP
Quote:
Originally Posted by ilkercatal View Post
It's my bad I forgot to add a video and another picture. Problem is actually for both but left is in worse condition. As, I mentioned I installed 2 new (very cheap ones) struts, 3 new mounths in the rear as well as replaced a broken spring on the left side. Just over 1500 miles and now my strut is (right side) about to pop out of strut mount again.

Do you think installing good stuff (like i did for front at the same time) for rear and also installing a aluminum bar on top of the strutt mounts in rear would reduce this crazy tear problem. Since I bought the problem, I have never been happy with suspension, always noisey ((
Its odd that you are having the push-through problem on just one side. On the passenger's side it appears the rubber is completely separating from the stationary metal mount. That's very bad for your mount, and prevents the shock from doing its job correctly. Are you positive you installed all the proper washers onto the shock in the correct direction and correct position? If so, you probably have a defective mount that should be returned and replaced with a new part. What brand did you install? Installing "good stuff" can't hurt. Meyle makes RSMs that are designed specifically to prevent the push-through you are experiencing.

Installing a rear strut tower bar is a band-aid and may not even help your problem anyway - depending on how it installs onto the car. Typically they mount onto the threaded studs coming out of the rear shock mounts. Mounting in this way would do nothing extra to prevent the rubber from pushing through.
__________________
BMW CCA member - Peachtree Chapter
LeMansteve is offline   Reply With Quote