View Single Post
Old 10-04-2012, 09:48 PM   #35
hi its me alec
Registered User
 
hi its me alec's Avatar
 
Join Date: Oct 2004
Location: Minneapolis, MN
Posts: 15,136
My Ride: BMWs + 1988 Pathy
Send a message via AIM to hi its me alec Send a message via MSN to hi its me alec
Quote:
Originally Posted by GSherbs View Post
If you've changed parts, then I'd say you do *not* have the original cooling system.

Period.
I agree. I haven't changed anything except for my original coolant from 1998 (once,) which is what I said in the OP.

Quote:
Originally Posted by E46Mango View Post
Yes you should be worried. Rolling the dice every time you start your car. Comes down to how lucky you feel. your low coolant light came on for a reason. your expansion tank has a crack on it. pressure drop test wont reveal anything if your car is cool. once up to temp, crack expands and water comes out
My pressure test was done about 20 minutes after a 20 mile drive, I'm pretty sure it was up to temp. Especially because the coolant light came on right when I floored it to merge on the freeway. I'm not worried because it turned on and off, and I checked my parking spot for leaks and didn't find anything. I think it's more likely to be my sensor than anything else. They didn't top my coolant off because they didn't have any BMW coolant in stock, and the light didn't come back on when I drove 40 miles later on in the day.

Quote:
Originally Posted by RKiepper View Post
221K and I'm still on my original water pump...
Damn dude, be careful with that. My friend has 179k and his just seized up on him last week.
__________________
WTB: Complete e46 M3 rear end


Last edited by hi its me alec; 10-04-2012 at 09:51 PM.
hi its me alec is offline   Reply With Quote