View Single Post
Old 10-06-2012, 03:00 PM   #104
Busabos77
Registered User
 
Join Date: Jun 2011
Location: NH
Posts: 858
My Ride: 04 Tiag M3 E46
Just finished cleaning my interior with Meguiars interior detailer... I took some photos but the interior cleaner made it a little shiny. Once the cleaner dries out and gets absorbed, it should go back to matte finish... I installed my grey front seats to be able to drive the car and see if there was anything else that we forgot to connect... So far so good... All the controls, dash lights and ac vents are working... Only problem I had was the sport button mode. I tried pressing it and I just did not feel the pedal sensitivity that it normally gives. The light for it turns on so its not the fuse or connection. I even texted m3freak86 (Chris) and Josh about it and also tried to contact EVOLVE... Finally I got the answer from EVOLVE... The battery of the car was disconnected for 2 weeks to avoid the airbags blowing up on me. Sal at EVOLVE told me to give the car to adapt again since the adaptations get reset if you unhook your battery for that long... So for all of you guys that have the EVOLVE Tune, if you do plan in storing your car over winter, get a trickle charger. I have a Trickle Charger but like what I said, had to disconnect the battery because of the airbag... So all is well!!! Right now, the car looks funny because of the grey seats up front but it felt good to drive the car yesterday and today and hear it! Damn I hate driving my other car!!! LOL!

DETAILED PHOTOS FOR BRANDON... (He asked me to take some to see the stitching/pipings)








REAR SEATS ( Still need to install the middle part)




HOW THE CAR SITS AS OF NOW...
















Busabos77 is offline   Reply With Quote