View Single Post
Old 10-19-2012, 12:15 AM   #5
jneumann
Registered User
 
Join Date: Jun 2009
Location: Wisconsin
Posts: 1,065
My Ride: 323i, 530i, Z4 3.0i
Send a message via AIM to jneumann
Quote:
Originally Posted by ryannel2003 View Post
Welcome the forums! I bought a bit of a fixer upper myself so I understand where you're coming from with that.

Honestly though, the rough idle could be anything. I would suggest searching for user "jfoj" and clicking the links in his signature. He has a whole list of things that could be related to the idle. As for inside the intake, mine looked similar and I have no performance issues so I wouldn't worry too much about it. Curious, do you know if anything on the cooling system has been replaced? At that mileage, you're looking at the least a water pump, expansion tank, and thermostat. It's very easy DIY. I'm not a mechanic and I never worked on my previous cars, but these are very easy to work on and the parts aren't that expensive either.
Listen to this man.

No codes being thrown? If you are slightly decent with computers, wouldn't be a bad idea to grab a blue VAG-COM KKL cable (FTDI chipset) off ebay for $12 and reset adaptations, read out fault memory, etc.
__________________
E46 323i Sport/5 speed/TiAg | 242k miles
E85 Z4 3.0i Sport/6 speed/Toledo Blue | 96k miles
E39 530i M-Sport/5 speed/Topaz Blue | 231k miles

Dynavin Android | Laser Interceptor | GRE PSR-800 | STi-R+ | M3 seats | 50W 4300K FX-R Retrofit | Solid black interior | Mtech II front bumper | Koni FSDs
Member, Three Pedal Mafia | Long informative article on oil | BITOG German Castrol FAQ

jneumann is offline   Reply With Quote