View Single Post
Old 11-05-2012, 10:20 PM   #4
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,172
My Ride: '06 330CiC, '03 M5
12.0 Volts is really a low battery.

See my signature for the Hidden OBC Menu, you can bring the battery Voltage directly up on your dashboard.

You should also check your charging Voltage as well.

There is a engine to body ground that can go bad on the passenger side of the car to cause the charging Voltage to be low.

Also check your coolant temp with the hidden OBC menu and make sure the engine is running warm enough.

What readiness codes have set?

Unfortunately you may still have a secondary air system problem that has not triggered a code that may be causing your O2 sensors to not clear quickly?

You need to make sure the SAP actually is running, the hose from the SAP to the vacuum control valve is good, there is nothing in the vacuum control valve restricting the airflow and you are actually getting vacuum to the control valve for the first 90 seconds or so on cold start.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote