View Single Post
Old 11-06-2012, 04:31 PM   #1
st0nec0ld
Registered User
 
Join Date: Nov 2012
Location: England
Posts: 2
My Ride: 328ci
328ci power steering advice needed

Hi Guys


I need help,
I have a bmw 328i 2000
On saturday i fitted a new p/s pump LF20 and a new resevior bottle checked all pipes no leaks re-filled with new at fluid, started car and no power steering,I wasnt concerned just thought it had trapped air,car was running about 5 mins i revved engine to 4000 rpm and power steering worked went out for a drive and all is well,didnt drive the car the next day so monday i get in it start it and no power steering.Revved car to 4000 rpm and p/s kicks in and all is fine,Until this morning same thing doesnt work from start until car is revved and it only seems to do it in the mornings the rest of the time it works from the start, I just cant think what it could be if it was air blocked then once the air comes out then its out, if it were blocked then it would be constantly blocked, Someone advised there is a banjo bolt that holds a check valve,now if this somehow was getting stuck untl the car is revved which im guessing would increase pressure in the line and pop the valve open, or could be that some how there is still air in it?
But i dont understand why this would only happen in the cold THIS IS REALLY DOING MY HEAD IN, STRANGELY THE PROBLEM WASNT THERE BEFORE I FITTED THE NEW PUMP HELLLPP
st0nec0ld is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.