View Single Post
Old 11-19-2012, 07:08 AM   #1
Big Girl Panties
Registered User
 
Join Date: Nov 2012
Location: Miami
Posts: 2
My Ride: 2002 325i (E46)
Coolant & A/C drama...seeking advice

Hi all:

Hoping you can lend me your advice. Started about 4 days ago ~
1. Defroster mysteriously kicks on every time I start car.

2. A/C goes warm every now and then (blowing no cold air) then reverting back to cold. (Replace Final Resistor Unit aprox 4 months ago, so doubt its that)

3. Yesterday, after driving 10 miles, heard Expansion tank "gurguling" after parking. Lifting hood, saw minor about of water "blurping" from rad cap. Under car, saw significant leaking mid way thru car under section, closer to driver side.

4. Checked oil: very low. Dry on dip stick. Filled it with 3 quarts, showed it was quite full, so it wasn't totally empty of oil.

5. Today, have not driven it, oil level still same. Filled rad with 50/50, removed bleed screw, allowed coolant to over fill in attempt to remove air. Started car, ran A/C on high heat. Heat never blew hot, only cool. Within 5 mins, coolant light illuminated, leak underneath seen again, quite rapidly leaking.

So, cannot tell what the association is with the defroster, A/C temp changes, low oil and leaking is.

Would really appreciate all opinions.

Side note: Power steering pump is bad. Steering has been quite difficult, was ready to take it in this week to change out. Had it changed out 2.5 yrs ago, but the dang part went bum on me. Any correlation to this, ya think?

Many thanks!

Christi
Big Girl Panties is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.